Need help with naked edges and objects shades not visible please

Hi, I am new to Rhino but I have been asked to do this project for my university course. I am struggling to fix the naked edges. I have tried to use many commands but unfortunately I couldn’t manage to fix all of them. Also, whenever I use the extrude tool, my solid objects are not shaded as it supposed to (it’s only framed). I have attached the file and a screenshot.
Thank you in advance,
Final building.3dm (608.5 KB)

when i open your file everything is shaded and the isocurves are off as well. This is controlled in the display options of Shaded. Try restoring to defaults.

Hello - it looks like you have the closed objects as well as some open ones in the same locations. Try the selection command SelOpenPolysrf and then delete or Hide these - the rest are closed as far as I can see.

Does that get you what you need?


Thank you for helping out but for some reason I am still not able to display the shaded parts. I tried both to tick and untick the ‘show isocurves’ option.

Yess, it does thank you so much!!!

Hello - if the default Shaded viewport display mode is not showing your objects shaded (right?), please run the SystemInfo command in Rhino and post the results here.


Hi, that is the issue I am having…
These are the result:
Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Educational, build 2019-07-09
License details: Cloud Zoo. In use by: Manisha Saha ()

Windows 7 SP1 (Physical RAM: 8Gb)
Machine name: USER-PC

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GT 520 (NVidia) Memory: 1GB, Driver date: 3-23-2011 (M-D-Y). OpenGL Ver: 4.1.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10 NVIDIA via Cg compiler
Driver Date: 3-23-2011
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - almost certainly is the old driver making life difficult - let’s see if there is anything newer available -

Open the Notifications panel (Panel menu) and look for a notification about drivers - double-click on that and follow along to get to a newer driver - download and install that and see how things work.


1 Like

Here’s the latest driver:

That’s clearly a very old system and well past it’s expected useful lifespan.
I hope you’re considering replacing the computer fairly soon.

Thank you for you help, your link was really useful and yes I am aware that my device is really old but I am going to replace it very soon

Did the updated drivers help?
Because the graphic card is so old, and the updated drivers are not new enough to be past the issues created in Windows 10, I was concerned they would not work.
I would not recommend attempting to update that system to Windows 10.
Leave it on Windows 7.

Hello, it did work for the saved files but when I try to create a new file for another project it still does the same. I would have to see if I get the same issue when I get new device.
But thank you again