Need help creating a wave-like surface

unhandled

(Catfang) #1

I’m trying to create a surface similar to this:

th%5B1%5D

I’ve tried using some defining curves and loft (ended up too muddy and linear) and could probably do it with HieghtfieldFromImage by (re)creating the image (not desireable). Is there a way to do this by defining the wave crest curves and/or baseline points that I’m missing? Seems like Drape should be an option as well, but I’ve been unsucdessful so far to get anything remotely close. Hopefully someone can walk me through a process that results in something similar. :slight_smile: TIA!


#2

Continuing down this path would be my advice. Building the original curves is the tricky part. A straight loft through all the curves should be the easy part.

There might be some gains to be made by building the curves with some sort of grasshopper definition, but that is outside my scope of expertise.

Heightfield and Drape probably won’t get the well defined edges.


#3

@catfang, i’ve tried it manually using these steps:

Create some parallel lines in xy plane
Made _Spiral _AroundCurve with variing turns around the lines
Created the surface with _Loft using straight sections
Inserted pairs of Knots using _InsertKnot near the spiral curves
Changed the surface degree using _ChangeDegree to U=3 V=3
Turned on points and selected the 2 points between the spirals, then _SelV
Moved the rows of 2 points between the spirals slightly down

Here is the file: SpiralWaves.3dm (522.7 KB)

_
c.


(Catfang) #4

That looks awesome, but I’m unable to recreate it! After lofting the spirals, I get an open polysurface. When I try to place knots on the surface (or ChangeDegree) I’m unable to select the surface. What am I messing up?


#5

@catfang, i’ve used these settings for the _Loft command:

grafik

This happens when your loft is a polysurface not a surface.
_
c.


(Catfang) #6

Try as I might, I can’t seem to get anything but open polysurfaces out of Loft. Do the spirals need to be based on strictly parallel lines? (I tried your Loft options and still came up with the same polysurface issue.)


#7

@catfang, it could be that your crease splitting is the cause, set it like below:

_CreaseSplitting _SplitAlongCreases=No

then try to _Loft again. Any better ?

_
c.


(Catfang) #8

Yes, that seemed to do the trick! :grinning:

A couple questions though, if you have the time…

I get what’s going on for the loft and moving the control points to get the concavity, but what do the InsertKnots and the ChangeDegree do? It was not visually apparent to me.

Thanks a ton for all your help! :smiley:


#9

@catfang,

currently the surface has degree 1 in one direction which makes it possible that is has sharp edges. I wanted to get rid of them but filleting is no option as the angle between the cavities sometimes is zero. So i _ChangedDegree to U=3 V=3 but this smoothed the sharp edges too much. If you insert knots near the sharp edges, then change degree, the details of the sharp edges are preserved much better.

_
c.


(Catfang) #10

Thank you so much! That was extremely informative and helpful! Next stop is the CNC machine! :slight_smile: