Naked Edges after importing from sketchup

rhino

#1

Hi, I am trying to import the file from Sketchup to Rhino for 3D printing. Before splitting the model to a fit in a cube for printing, I did the ShowEdges and clear all the naked edges. However, right after splitting and using Cap command, there are still naked edges. I tried to create a closed shape but the naked edge is still there. Is there any way I can fix this? Thanks.


#2

Did you try running testremoveallnakededges? It’s not in the drop down menu so you have to type it in fully at the command line.

Dennis


(Pascal Golay) #3

Hi Kevin - it looks like you have multiple overlapping faces there - try ExtractSrf and click on the nakeds - what happens? Can you post the object here or send to tech@mcneel.com ?

@dmoyes the command I think you have in mind is testRemoveAllNakedMicroloops. If so, it will not help here…

-Pascal


#4

@dmoyes I can’t find the command testremoveallnakededges.

@pascal After I typed in ExtractSrf command and click on the naked edges, more naked edges appear. I did able to delete the overlapping faces and this is the result (See image), What I can do to close it. If I use planar curves, I still get naked edges.


#5

Hello again, I think I solve a bit of it. Using the command you recommended ExtractSrf I can take out my model into pieces and create a close planar each piece. I still get naked edges on the big piece. Do you know any other ways?


#6

that’s sort of a great example of something that should be modeled in rhino instead of sketchup… working with that in rhino is going to be a headache.

is there a reason you need to use the sketchup mesh instead of remaking it from scratch with rhino?


#7

My mistake. It’s testremoveallnakededgeloops


#8

I started using Sketchup before Rhino and it seems a bit easier. Not really use to Rhino yet. I could start over but the deadline is next Tuesday for printing.


(Pascal Golay) #9

Nope! repeat after me: testRemoveAllNakedMicroLoops

-Pascal


#10

Pascal

Thanks so much! I tried the dmoyes version and it didn’t work and I though this must be something for v6 and sort of shrugged it off. Your last post with the = mark at the end caught my eye and gave it another try and was thrilled to see it works in v5. I’ve added it as an alias since I will never remember the whole ‘secret handshake command’ but can’t wait to use it. I’ve got all sorts of silly workarounds to deal with those little bothersome microloop chingarerras but maybe I won’t have to resort to them with this.


(Pascal Golay) #11

= was a fat-finger special. Maybe I’d better leave it! BTW, in V6 this is a real command but renamed… I do not have it available right this second to properly verify the new command name but I’ll update later if no one jumps in.

-Pascal


#12

So the = sign is not needed and the command still works? If you say so. Lets get a cool name and icon for it along the lines of ‘Roadkill’.

Maybe this


(Wim Dekeyser) #13

Must be this one then:

RemoveAllNakedMicroEdges

(Pascal Golay) #14

That’s the chap - thanks.

-Pascal


#15

Thanks everyone for helping. I decided to import the file to rhino and trace it from there.


#16

This is EXACTLY the reason I assigned it to a function key!!!