Naked edge with flow on surface

Every time I flow a surface from a base to a target surface I get a naked edge at the seam. I am not sure what the issue is but I would like to be able to resolve it because it is a persistent problem.
Thank you!
My file is here

Hi Courtney - the first thing I’d change is the file tolerance - modeling at .1 units is just not a good idea, especially for something at this scale. I’d start over at .001: untrim and retrim everything.[]=tolerance

At .01, I still get a bad object, though it is fixable - I guess this is what you want:

new ring (12.5 MB)


oh thanks Pascal. I actually was modeling in .001, but I changed it to see if I could join with that tolerance but was unable to do it. I forgot to change it back. Do you have any idea why I keep having that problem? How did you fix it? I tried blendsrf and a few other things. Thanks again @pascal

Hello - for one thing, flowing is not an exact operation… having things roll around an meet exactly is likely to fail fairly often, that is just the nature of the refitting that has to happen. But your base model was a bit un-clean, it seems to me - I retrimmed and rejoined everything before flowing and it was better - But, I see I screwed it back together in the wrong orientation…


ok thanks! I am still trying to learn- so do you @pascal have any tips on how to make a better model? I started this one from scratch several times and was trying to do everything just right.