Mystery crosses

Attached is a file of a Sweep1 shape. What are the crosses showing just off the corners? They go away when I turn off isocurves, but what do they represent exactly?

Thanks,
Dennis
baseboard.3dm (620.9 KB)

Those be some completely wacky surfaces… Explode your object to isolate them.

How did you make that? I cannot reproduce the problem when using the inside “U” as a rail, I do get some weirdness when I use the outside “U”, but not the same as yours…

I got the same wacky surfaces here with the inside rail. I’ll YT that…
https://mcneel.myjetbrains.com/youtrack/issue/RH-54138
-wim

Hmm, wonder why I didn’t get them here…
baseboard-msh.3dm (639.3 KB)

That is weird, yes. I get those wacky surfaces with your input as well. (6.18.19216.18471, 08/04/2019)
-wim

OK, I’m still on 6.17…

But that shouldn’t be it - If the audit command is correct, Dennis is on 6.16:

Interface Name: Rhinoceros 6.16 - Commercial, build 2019-07-09 - (compiled Jul 9 2019)

:exploding_head:

@wim, @dmoyes, @Helvetosaur - I get the right answer if I true up the shape curve - make sure it is planar and the vertical leg is exactly over the path. It is not off by much, and I have not found where it’s off.
It’s the vertical leg of the shape curve- the ends are microscopically not on a vertical line.

-Pascal

Thanks for that. I’ll get out my microscope! Does it have anything to do with the tolerance settings?

Hello - I don’t think so - tolerances are quite tight in this file. Just fyi, fixing is a matter of selecting the vertical leg points and using SetPt in XY only, to set them to the end of the path curve (I used the inner ‘U’)

-Pascal

Understood. Thanks Pascal.

Thanks, @pascal. When I filed the YT report I tried to simplify the profile curve as much as possible. If it was reduced to only that inside vertical line, all went well. With the added fillet curve at the top, it failed.
-wim

hm - interesting as well… I wonder what’s is up with that - anyway, I guess Lowell’s on it…

-Pascal

1 Like