My screen white's out when i press and hold a button

unhandled

#1

my screen white’s out when I press and hold a button. (Rhino 6 WIP. / I’ve also had this happen in RHino 6 commercial)

sometimes it just flickers once to white, then comes back to normal. Sometimes it stays white for about 4 seconds as long as I keep pressing. Sometimes it just flickers without any input.

here’s a video:

https://photos.app.goo.gl/XKERz5EeowTMLrXI2


(Pascal Golay) #2

Hello - ‘press and hold a button’ - can you be more specific? What exactly are is the mouse pointer over when you press and hold, and why are you doing this, what should happen?

-Pascal


#3

Pretty much any button / icon in the upper toolbar or main / standard toolbar to the left.
Press and hold is to get acces to the sub-buttons. But it happens with a any button that I would hold down.

I have a HD screen. (Dell Canvas 27) maybe that’s an issue?


(Pascal Golay) #4

What happens if you click directly on the little black triangle on the bottom right of a button, does that cascade the toolbar?

-Pascal


#5

Yes it does. All works kinda like it should, it just whites out.

It’s also not a consistent issue, sometimes it just happens for a while then it doesn’t. At the moment it doesn’t. so I can’t really test anything. However, the upper bar, (with the Rhino logo and file name) still flickers briefly even now, any time I click on a button with sub-buttons.


(Pascal Golay) #6

Hmmm - Can you please run Help > System information and paste the results here?

-Pascal


#7

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)

Quadro P5000/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.16)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-30-2017
Driver Version: 23.21.13.8816
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Bongo 2.0 (64-bit)\BongoUI.20.v60.rhp “BongoUI20v60”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Pascal Golay) #8

Just to test, can you disable these two plug-ins in Options > Plug-ins and then restart Rhino and see if the problem shows up?

-Pascal


#9

still the same issue. Also the full screen white-out came back , but just once.

I also had the same issue in RH6 -WIP. I don’t think I had any plugins loaded there as it was a virgin setup


(Pascal Golay) #10

OK, thanks for testing… I have a similar card here , p4000, and I’ve never seen this problem. I don’t have a good idea. Is the toolbar file the default V6 one?

-Pascal


#11

should be, I didn’t mess with any. Just standard toolbars


(Pascal Golay) #12

And, really just a shot in the dark, have you tried a different mouse?

-Pascal


#13

Same problem with different mouse. Also when I use the pen directly on the touch-screen of the Dell Canvas.


#14

I even put the touchscreen function off, to see if that was the issue. but, no, still the same.


#15

in fact, I can see the same issue in Rhino 5.

I also turned the Dell Canvas completely off, and checked on the laptop screen only, just to make sure it has nothing to do with the Dell Canvas. …but still the same issue.


#16

I wanted to see if there’s any progress on this issue.

Today it even happened when I opened a clean file 9after having updated to the last service release just before that), first time I click mouse button it goes to full white screen, with in upper left corner written"Boolean Union" (which I didn’t click on), together with a left mouse button icon.

The white screen prevented me to get to any other window, so I couldn’t launch task manager either to stop it.
When I shut off my monitor, and the laptop screen took over, for a second or so, I could see the Rhino environment. Same thing on the monitor when I switched it on again. It seems like the white screen is just an overlay screen that blocks me seeing any of the other windows that are open.

Very annoying! It’s been months now that I’ve been facing bugs like this in Rhino which prevent me from having a normal workflow. Can someone please look at this???