My InterconnectPoints in Kangaroo 2.42 not working. Need some help

Hi everyone. I tried to interconnect some random points in Grasshopper 0.9.0076 and Rhino 5. It seems to me my InterconnectPoints in Kangaroo 2.42 cannot work. The input is showed correctly in InterconnectPoints, but the output of it is always Null. If anybody can gimme some help? (@DanielPiker , hope you see this.) Many thanks for your time~

Please upload your file.

Thanks, @parametriccuriosity . (9.4 KB)

It’s a battery problem. Like coding name confliction or something (10.5 KB)

Yeah, I tried Kangaroo 0.099 then, it worked. But initially I only had Kangaroo 2 in my Grasshopper, there was no confliction problem for sure. This made me wonder if the software not compatible with my computer.

Anyway, thanks for your reply, @Liu

Sorry, this was a bug in 2.42
It’s fixed in 2.5 (for rhino 6)
You can also achieve exactly the same thing by connecting your list of points to both inputs of the cross reference component, with the option set to upper triangular strict.

1 Like

Got it. It seems any option is ok.

I’d like to try 2.5 someday, appreciate. @DanielPiker

“seems any option is ok”
Just beware that if you use a different option such as holistic you are getting duplicate lines (from A to B, and from B to A), and zero length lines connecting points to themselves, which will often cause problems downstream.

My bad. Just found the values in outputs are different under these options. :blush: