My dimensions are showing way to large

This problem has come up again - I don’t recall how I remedied it after a couple years and looking around for a means to do so is frustrating. The settings that would imply the fix don’t seem to do so.

Shared with CloudApp

Setting the ‘scale all sizes’ does nothing.

Hi - all appears to be correct from those images.
You have set the font height in layouts to be 1.5 units and use model scale 1.0, which will give you annotations that are 1.5 high in your model. And from the grid, that seems to be correct.
-wim