Moving a list of points ( list generated in python )


#1

Hello.

what my current problem(s) is all due to lists I generate in python. if I divide for instance inside python a curve into equal segments I get ( lets say ) 20 points, this is not only happening with me in this list, all lists I generate inside python and then I try to transform or adjust in any way, are not considered an object.

in the script attached, all is fine, until line 23.when I use the list I created ( OLIST in this example ) as the object, the error occurs.

how can I apply functions on lists that are not fed into my command, but generated in Python???


#2

I think here you can…

  • move scaled before dividing. (fastest)
  • add “Olist = rs.AddPoints(Olist)” before last line. (not sure)
  • or move points yourself “moved = [pt + EvaltanShift for pt in Olist]”

You are, btw, not having the latest version of GhPython.


#3

Marcus thank you so much! ive tried the 2nd one "Olistnew = rs.Addpoint(Olistold)"
and it perfectly worked! really appreciate it

thanks again.