"Moveface" command hide faces

Hi,

When i use the commande “moveface”, some of the faces disappear.
Is there a way to fix it?



Can you post the file with that object?

Also run SystemInfo in Rhino and copy/paste the results here.

The file is too big to be posted. I juste realize that this problem happen when i use “moveface” command on small objects like little steel plate in my model.

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16351, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Commerciale, build 2023-12-12
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 3-16-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA RTX A2000 Laptop GPU (NVidia) Memory: 4GB, Driver date: 11-2-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.79
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-2-2023
Driver Version: 31.0.15.3779
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab PDF From Rhino\SimLabPDFExporter.rhp “SimLab PDF Exporter”
C:\Users\Julien.Labrie\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Iris\0.7.1\Iris.V7.rhp “Iris” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.36.23346.16351
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Just select the object you show in the picture above and use Export selected… can’t be very large…

test.3dm (132.9 KB)

Hi Julien - thanks, I see this as well. Your box is very far from the world origin.
Point in world coordinates = 367862159.34,5335918092.31,704.05
Most likely the render mesh is not correct at this location.

-Pascal

Yep that’s the problem. I am working on a georeferenced project. That is why my box is so far from the world origine. Is there a way to use temporary world origine so that i can fix this problem but still be able to import other georeferenced objects that will be insert at the right place?

Thank you

Hi Julien - there is this
https://wiki.mcneel.com/rhino/farfromorigin
The info there is no longer 100% accurate - render meshes are double precision now - but the workaround might possibly be useful.

-Pascal

1 Like