Move To Point / Rectangle Mapping Problems

Hello Forum,

I’m currently working on an project for automating railings.
As i learned here: Copy object to another positions
I can compute one filling and move it to the other rectangles. But I’m running into a problem.

This is my computed filling:

Wether I use Move To Point or Rectangle Mapping, I always end up with this.

When I use my “test rectangle” it works.

(I’m using Perp Frames, because I want it to be an free geometry input)

I’ve already noted that it’s a different output datawise but i couldn’t determine why.

So I changed it to Move to Point, also tested it there with the actual line and an “fresh” Line from 2 Points, but I got the exact same result.

What am I overlooking?

Maybe because its a list and not a tree and you move one by one to the next from the list instead the whole list inside a tree.
If the connection line between the components are dotted its a tree data structure if its not doted then its a list.

1 Like

@flokart it worked, thanks!

I did notice that there are different lines, but had no clue that it differs the data type :person_facepalming:

if you right klick in the input and output of each component is the option to change the data structure from tree to list and vice versa.
good you solved your problem.