Move command slower in V6

performance
unhandled
move

#22

Hi Pascal,
Thank you million times! It helped. So it is related to the plugin. Is this issue already recorded as a performance bug? And is there any chance for fixing it in forseeable time? Thanks

Petr


(Pascal Golay) #23

@fsalla - can you help at all here?

thanks,

-Pascal


#24

Hi Petr, we haven’t heard from such a similar behavior before related to Lands or VisualARQ. Is this happening with any document or just with a specific one. In the second case, can you send it to visualarq@asuni.com so we can check it out?
Which versions of VisualARQ and Lands are you running?
Do you have any Section or Level Cut plane activated? (if you had a big amount of geometry and a section enabled, it might explain the slow performance, in comparision to the performance when no sections are enabled).


#25

Hi Francesc. Well, in my case, I am experiencing this issue in bigger 2D drawing file. The larger the file is, the worse and more laggy are the commands move, copy, mirror, gumball etc. I was very surprised, that my new worsktation doesn’t handle such a file. But after disabling the VA, Lands and Tibidabo, it works much better and the difference is really visible! I am running the most recent versions of both VA and Lands (VA 2.3.6. and Lands WIP 6).I am not currently working in VA template, so I do not use any of VA commands and neither Section nor Level cut are activated. Plugins are just loaded to rhino, but I am not working with them within this project. I can send you the model in the evening, I am AFK at this time.

Thank you,
Petr


#26

Francesc, I have just sent the file to the email address visualarq@asuni.com

Thank you!
Petr


#27

Hi Petr,
I’ve got your file, thanks. I have VisualARQ 2.3.7 and Lands Beta VII and it works fast and nice for orbiting, moving objects, etc…
Try this:

  1. Uninstall VisualARQ and Lands from your PC
  2. Download VisualARQ 2.3.7 and install it.
  3. Download Lands Beta VII and install it (we released a new built this week)

Let me know if the slow performance persists.


#28

Hi Francesc, ok I’ll give it a try. I just wonder, @pascal, how did you know that these plugins could cause the performance problem? Do you have any experience with it? Or was it reported in past?

Petr


(Pascal Golay) #29

Hi Petr - it’s a reflex - if things go wrong in Rhino, blame a plug-in! Actually, of course we look for Rhino issues, but mainly it is pretty easy, to eliminate a plug-in as culprit by disabling it so that is often a thing to try early on when troubleshooting and occasionally it turns out to be just that.

-Pascal


#30

Hello,
so I installed VA 2.3.7. in the RH 6.12. The performance seems slightly better to me. But there is still visible difference. I tried to hit testmaxspeed command with VA enabled / disabled. The result is:

2 sec with VA disabled
5,3 sec with VA loaded