Mouse selection area/precision on normal click

Hello gents, ladies,

Something that has been bothering my workflow for a while now and hoping there is an option to change this. The precision of a mouse-click to select an object. I click with the point of my mouse pointer on an object, but rhino then prompts which of multiple objects I want to select, even though the objects on screen are far enough apart for me to easily see which one I click.

I’m hoping this is a setting which I can easily change somewhere in Rhino.


1 Like

Perception is a personal thing, of course, but I would almost say that this is mouse-specific.
In order to test, I wonder if it is meaningful to post an example with a named view in a floating window of a specific size…

I also get the pop-up but that’s only when things really are on top of each other (if you ask me).

I would not say it is mouse specific since it is only in Rhino, in other software it does take the ‘exact’ point of the mouse.

Screenshot, red cross is where the point of my mouse pointer is when I clicked.

So, I would still like to have a small area around my mouse to also detect clicks, but the area is just too big for the current part of the project.

I suppose that in that specific screen shot, you are not clicking on anything and Rhino has to look for the nearest object (within range). I assume that the block instance # 2 in the selection menu is the table row with NBR that is above the Stainless steel row. Those two blocks share a common line (I assume) that is equally far away from the mouse pointer as the text string curves that you appear to be targeting. In that particular case, making the detection area smaller would then not select anything.

I understand what you mean, but the main question is, is it possible to make the sellection area smaller, because if I zoom further out and select the text, it also detects the two other lines you just mentioned of both the row above and below.

“nearest object in range” to further display the problem i’m having, here I click on the text and it does not know which of the 3 rows I want.

Hi Peter- I thought there was at least a test command for the pick radius, but I cannot find it. I’ll see what I can find out.


@pascal thanks for the effort!

@pascal Have you been able to get any info?

Peter! Mikko says:

"Yep, it’s possible. Right now it’s hidden in the scriptable Options, at

-_Options _ModelingAids _MousePickboxSize

The default is 7."



Great! I am going to try out if it works better to lower it a bit, or that it would be less convenient in other parts of the workflow.



YAY! Thanks Pascal. I was looking for this as well.

I’ll probably end up making a few buttons to switch between modes. The default is good for certain things, but others, I end up frustrated as well.

I’m glad you found it, and posted it.

I am having this issue in Rhino 6. I have Rhino 5 open at the same time and don’t have an issue. I don’t have the option to change the mouse pick box size.

Hello - in options with a dash in front, you can get there:

! -_Options _ModelingAids _MousePickBoxSize

See that?



That did it, after copy and pasting the command. Couldn’t get there by going through the pull down options menu. Mine somehow got changed to 30. Thank you!!!


Hi thanks a lot - it works well in Rhino6!
This was driving me crazy. The option should be visible in option.

Hi - this setting is exposed through Rhino Options > Advanced. Granted, that doesn’t necessarily make it easy to find, but it is, after all, a setting that people probably don’t change at all.

1 Like

Mine also got bumped to 30 for an unknown reason.

Glad I found this post.


Thanks for that screenshot!
The line “-_Options _ModelingAids _MousePickboxSize” stopped working after an update and this have been driving me crazy for months! You made my day!

1 Like

mine was also changed to 30 suddenly and for no detectable reason. also thankful for this post

Mine as well, last few days mouse pointing and selecting was quirky,
i knew there is a why to change that definition, but didn’t find it,
Did what @pascal had suggested, and as well found that the value had changed to 30…
that is strange… changed it back to 7 & mouse pointing selection is back to normal, so thanks !