Modeling 3D textures - problem with blending curves


#1

Hi All!

I am new to Rhino and am currently doing a lot of tutorials to get the knack of the basics of the program. Most problems so far I have been able to solve but with this one I require a bit more help.

The tutorial I am working on is the 3D texture modeling on the site. When working on the first texture you first need to split your curves on the surface and then use the blend option to extend your curve from one object to another. Somehow I cannot get this done, some work, and with others I cannot select the split curves. As if they seemingly don’t exist. I really do follow all the steps provided in the tutorial but am wondering if there might be slight adjustments in versions of the program?

I have attached my file and would be very grateful if someone could take a look at it and help me find out what I’'m doing wrong.

Many thanks in advance,
Morgan

tryout7_3dtextures.3dm (199.7 KB)


(Pascal Golay) #2

Hi Morgan - it may be that you are trying to blend to the surface isocurves - these indeed do not exist, as curves in the file, they are only properties of the surface and displayed on screen to help visualize the surfaces. The successful blends in your file have come off of the radial edge curves - these are also part of the surface but are generally accessible to commands that require curves.
To get what I think you want, you can use ExtractIsocurve using the ‘Quad’ odnap to extract radial direction isocurves that will respond to BlendCrv, or use the Edges option in BlendCrv to force the blend to come off the surface edges at 90 degrees.(Quad osnap as well). I’ll see if I can make you an example.

@Morgan_Ruben - see if the attached is what you are after - red = ExtractIsocurve, blue = BlendCrv, Green = BelndCrv with Edges option.

tryout7_3dtextures_PG.3dm (97.9 KB)

-Pascal


#3

hi Morgan you seem to have started somewhere with history, if you dont need that just use HistoryPurge to clean it. History can often block you from getting somewhere else and reacts like it just ignores your changes. after HistoryPurge it should work normal again. and you seem to have successfully used splitedge already it just does not show that as curves. just rotate the freestanding blend curve you already have 90° to the other side copying it and you can use sweep1 as shown on the video. after that use split and choose isocurve as shown.


#4

Hi Pascal, thanks for your reply. I will try your suggestions ans see if they get the result that I need.


#5

Hi Richard, Thanks for your reply. Yes I did indeed use history. Heard in a tutorial that it was useful to keep it on, was wondering about the implications however. I will try your suggestions and see if I can solve it.


#6

history is a nice function that can be very helpful when you know exactly how to use it. but i must say i also sometimes forget to deactivate it, the file gets large and slow and some things do not update anymore. oh i also noticed if you want to successfully proceed with this tutorial you have to delete those mirrored surfaces and copy rotate or mirror them over again, one side seems to have a different distance.


#7

Yes, your suggestion did indeed work! Many thanks! :slight_smile:


#8

yes that is very true I suppose. I have changed the distance btw, and deleting the mirrored surfaces should not be a problem, if we mean the same thing in this instance. The problem I still have though is that the edges dont merge properly. Remains a tiny gap. As such I cant join them. Any ideas how to work around that? I have included the updated file.
tryout7_3dtextures.3dm (339.6 KB)


(Pascal Golay) #9

Hi Morgan - it looks like the quarter circle surfaces do not match the blend curves -

How did you make the surfaces?

-Pascal


#10

Hi Pascal,
Thanks for your reply.
Well first I made the rounded shapes, copied those into a pattern en then used the extractisocurve using quad. I joined these isocurves using blendcrv. After this I did a 1 rail sweep between the quarter edge of the rounded objects and the blended curve. Then I used split surface by isocurve which gave me a not very neat result.
M


(Pascal Golay) #11

OK - somehow the revolved shapes do not match the blend curves though, perhaps you had the ‘Rebuild’ setting in the Sweep1 dialog? In any case, a simpler more precise shape can be made using Revolve. Splitting with an isocurve should work fine - snap to the Quad again to get the very bottom of the valley, or, split the curve ahead of time and revolve just a half.

tryout7_3dtextures_PG.3dm (534.0 KB)

-Pascal


#12

Yes I see that the shape you edited works perfectly. I do not, however, understand how I should use the revolve in this instance. I have only used it for closed shapes.


(Pascal Golay) #13

Hi Morgan - if you select one of the half-blend curves - I split your curve - and start Revolve, assuming the Top CPlane is the active one (Default in Perspective and Top views) snap to the inner endpoint of the corresponding muffin top, i.e. the center of that surface’s circle, so to speak, as the first point in the revolve axis. Hit Enter to force the axis to be vertical to the CPlane, and set the start angle (at the command line) to zero. Drag the surface around and snap to the quad or the other blend curve end point that is 90 degrees away, or just enter 90 as the revolve angle.
Does that work?

-Pascal


#14

Hi Pascal, Many thanks! this did indeed solve my problem.