Model showing vertex colors instead of texture mapping


#1

I’m opening a wrl file with a texture file but the texture isn’t being mapped, I’m only seeing the vertex colors (when I go to properties/material and uncheck texture, I see the same thing). I am in rendered viewport mode.

Has anyone seen anything like this before, any suggestions?

Thanks,
Sam


(Pascal Golay) #2

HI Sam - my guess is the mesh may not have texture coordinates, possibly, or the texture is not found - can you send the mesh? I’m not sure what the ‘priority’ is when a mesh has both a texture and vertex colors.

-Pascal


#3

Hi Pascal,

When I open it on my main computer it works just fine. But then when I open on a remote desktop computer, that’s when it seems to only be showing the vertex colors. I have moved the texture jpg to the same directory, so that’s not the issue. Perhaps there is a priority setting somewhere barried in the settings?

Just tried it with another wrl file, same issue, so must be something to do with the install on the remote computer. Any suggestions?

I can’t seem to upload wrl direct, but seems to be happening with all wrls anyway, let me know if it would still help to see an example and I will file share one.

Thanks,
Sam


(Willem Derks) #4

Hi Sam,

If you have access to the Remote machine, I’d see and try to view it there on it’s own monitor connected to the GPU, to find if the problem lies with the machine or the RD connection.
In fact my money would be on the RDP protocol not supporting openGL rendering and as such all sorts of issues with Rhino display can occur.
THIS old discussion suggests this indeed to be the case.

-Willem


#5

The machine is on Amazon Web Services, so I can’t get access to it. Say it is the RDP protocol, is there anything I can do to fix this on the remote machine?

Thanks,
Sam


(Willem Derks) #6

Hi Sam,

I’m by far no expert on this. To double check, go to the options page in the remote Rhino and find what there is for View:

There must be other remote desktop type software that relays the display as rendered on the remote machine…
For instance Teamviewer will let you share a screen and allow for the visitor to operate the mouse…yet that can be sluggisch

I guess it all depends on your needs…what is the reason for using the remote machine…and the need for accurate display?

As a complete sidestep, you could clear the vertexcolors altogether and see what that brings I dug up an old rvb and modified it to remove vertexcolors from a mesh…did not test thoroughly …
RemoveVertexColors_arrMeshes.rvb (656 Bytes)

Final thought: how large are those textures? If they are too big the RDP GPU emulator might not be able handle them. In that case a resolution reduction of the images could help. ( start with extreme reduction that work your way up to find the max)

HTH
-Willem


#8

I checked “do not use opengl for drawing feedback items” and it worked!

Thanks!
Sam