Model gets faceted in both shaded and zebra mode

Hi Guys

Good day.
I recently notice this error in shaded mode, it just happen suddenly. Somehow, my model gets extremely faceted even after I adjusted mesh display setting to ‘Smooth&Slower’.
This faceted problem also affected the zebra strips display, creating frustration…

Is there any particular setting I need to do in Rhino option? Or is this a graphic cards issue? Hope you guys can help me with this.

Thanks in advance :slight_smile:

Best Regards
Chua

I found the solution after restoring default in the shaded view. I have accidentally checked flat shaded.