Missing Letters on Grasshopper

I have installed Rhino, and wanted to use one of the plug-ins, Grasshopper. However, there seem to be a bunch of missing letters. Attached is a screenshot of what I mean.

Here are some steps i have taken to fix this issue:

  • restarted Rhino

  • Update Rhino

  • Restart my laptop (I am using a MacBook Pro)

However, none have resolved the issue. Could I please have some insight on this.

Thanks!

Hi,

Once close all after opening, try this

Cheers,
BVR

Hi, thanks for your reply!

I restarted Rhino, and put in that command. I also said ‘no’ to all of the questions.

However, my problem is still the same, I can’t see any text.

Copy paste your system info here from Rhino system info.

Sure, attached is my system info. Rhino Commands.txt (9.7 KB)

Thanks a lot.

Okay. Which plugin you want to use. Did you checked whether it has mac version too. Rhino official website recommends AMD processors for mac. But upto my knowledge this issue will be graphics part or grasshopper.

The plugin I used for grasshopper was just included in the RHino download, which I have the latest version of.

Do you have any other suggestions?

Thanks!

Unfortunately, I can’t reproduce this on my computer. In the meantime, I’ve logged a bug to investigate this more. Thanks for reporting it and providing your System Information. That’s the best first step.

Logged in:
RH-60673 Grasshopper: Missing character glyphs

Are you running any font management software on your Mac, or have you deleted/moved any system fonts? Macs sometime behave like this if there is a font conflict or the program is calling for a missing (system) font.

1 Like

This is a good point @stanek. @bhavisha It reminds me you might want to check your font integrity if you haven’t already: https://wiki.mcneel.com/rhino/mac/checkfonts

1 Like

@bhavisha,

Could you try to go to Grasshopper > Preferences > Display > Fonts and take a screenshot and post it here?

From there, you should be able to click on the font in the “Standard Font” section (top one) and select a different font, such as perhaps Arial or Helvetica.

edit: just checked, this doesn’t actually change the font used for the parts that aren’t working for you. I’m still investigating though and the above screenshot will help troubleshoot this.

Hi,

The issue has been resolved now, thank you so much for your advice.

Have a great day!

Regards,
Bhavisha