"Missing Dialog" Error when trying to export .STL files


#1

After updating to the most recent build I have been encountering an error when trying to export files as .STL. This error it only occuring on my laptop however, and not on a iMac that I also have access too. The normal export process starts where the tolerance dialog box pops up, then the polygon mesh build, then the ASCII or Binary radio buttons, and then after clicking okay two dialog boxes pop up. Both say "Missing Dialog The dialog for this command is not yet implemented.

I’ve tried uninstalling and reinstalling the new build already and that did not help. Also tried to export as .OBJ and that did not work either, the .OBJ files were corrupted and could not be opened by other programs.


(John Brock) #2

I’m running build 474 and I can’t duplicate the error.
I don’t know what to suggest.


(Marlin Prowell) #3

I cannot duplicate this either.

Starting with the 2013-08-22 WIP release, the Missing Dialog message will display the name of the dialog that is missing. Please duplicate this with the 2013-08-22 WIP release and give the name of the dialog that is missing.


#4

I updated to the 2013-08-22 WIP release and am still encountering the error. The missing dialog now reads, “The 15CSTLErrorDialog dialog for this command is not yet implemented.” I can now get simple objects to export, just an extrusion or sphere for example. More complicated designs made up of unioned parts are still failing.


#5

Update to .OBJ problem. Tried to import a .OBJ of the file into Netfabb and was met with an error stating " ‘/’ is not a valid integer." After that I gave Meshlab a try and it just crashed trying to import.


(Marlin Prowell) #6

This dialog is now implemented in the 2013-08-23 WIP release. The dialog says “The STL file you are saving is not adequate for creating rapid prototyped parts.” and then says to check the help file. The help file is not hooked up in Mac Rhino so perhaps @pascal (he who knows all) can shed some light on what the help file suggests.


(Pascal Golay) #7

Hi all- you should get this dialog if the mesh you are exporting is not closed. It points you to Help. Help (also [here][1], for Windows Rhino , look for STL in the index) says:

STL mesh export diagnostics
For some rapid prototyping machines, STL files must contain completely closed (watertight) polygon mesh objects.
You might want to do this to ensure that the meshes really do fit together before exporting them for use in an expensive STL job.
To test for watertightness
Join the mesh objects.
Conceptually, this command gets all the triangles into one bag, but it doesn’t glue the edges together. (The situation is similar to having surfaces that all fit together but have not been joined into a solid.)
Weld the new mesh object.
At the Angle tolerance prompt type 180.
An angle tolerance of 180 tells the Weld command to glue adjacent triangle points together no matter what.
number-4.pngUnifyMeshNormals.
This changes all the triangles so they are oriented the same way, that is, if two triangles share an edge, then they have the same idea of up.
To see if the result has any holes or gaps, type SelNakedMeshEdgePt.
If a mesh point is highlighted, then it is part of a “naked” triangle edge.
To avoid generating very large mesh files
round_bullet.gifStart with the Mesh command, which has the same controls as the render mesh controls found in Mesh Document Properties. The difference is that the Mesh command, however, produces a polygon mesh you can export. You would get the same controls by exporting the Rhino geometry to STL, but in general it is preferable to make the mesh object as a separate operation and export that.
round_bullet.gifThe settings that work best for STL will vary, but a good place to start is to go to clear the Maximum Angle setting and the Maximum Aspect Ratio setting completely. Set the Maximum distance edge to surface setting (which is the desired maximum distance between the midpoint of any edge of a polygon and the true surface) to something around the resolution of the rapid prototyping machine. About .005 inch (.125mm) might be a good number to start with. It may be that once you have determined which are the best settings for your projects and rapid prototyping machine, this procedure may become superfluous. Instead you may just want to export the NURBS objects directly and use your proven mesh settings when the object is converted to polygons during export.
round_bullet.gifOnce the mesh is generated, you can hide the NURBS object and inspect the mesh using the FlatShade command. This will show you a shaded view of the polygons without the smoothing tricks used by normal shaded views. If the mesh looks good, export the mesh to the STL file. If not, delete the mesh and try different mesh settings.
round_bullet.gifIt is best to only change one setting at a time to see the effects of that setting. It is best to only change one setting at a time to see the effects of that setting. If the mesh is fine enough but some areas do not work, try Maximum aspect ratio to something between 4 and 7. It is generally not worth setting Maximum distance edge to surface to much below the resolution of the rapid prototyping machine.

-Pascal
[1]: http://docs.mcneel.com/rhino/5/help/en-us/index.htm


#8

You might also look at the following article:
http://wiki.mcneel.com/rhino/faqclosedsolids
–Mitch


#9

I am now able to export the file in the newest release, 2013-08-23 WIP. I had been trying to create a mesh before export as suggested by Pascal versus having the Export command accomplish this function. This was a new issue to me I suppose because the dialog had never been implemented up to this point. It also seemed a bit odd because individually I could export all the parts of the object, but after unioning I could not export it as whole.