Misbehaving Offset

Hi all,
Apologies, I should have better analyzed the problem before asking for help.

The problem indeed not the boolean toggle, but something related to the offset algorithm in this definition.

error_offset.gh (9.9 KB)

The shapediver model should show 2 rectangles, instead the offset is missing.
Everything works fine in Rhino/GH

I think I can use a work around, but I’d like to understand what’s wrong with this for learning purpose.

Thank you for your help

Apologies, I edited the post as I realized the problem is not about a boolean toggle at all.

Cheers

It’s working fine for me:

Is it?

I actually see only one rectangle in your model too. Are you sure the offset isn’t missing?

Assuming the offset component itself is working, the problem seems to be connected to how I pick the larger one. I tried using either ‘filter’or ‘pick ‘n choose’ and in both case the offset geometry does not pass. It works just fine in Rhino though

Actually - you’re right. The offset is in fact missing. I’ve even altered your definition using Shapediver display geometry components to preview the original and the offset rectangle. The offset is still not displayed online. Somewhat strange. Maybe @pavol could take a look?


error_offset_210829.gh (22.0 KB)

@matteo.b can you double-check that your Rhino is up to date? When I open your definition on my laptop, the offset components don’t work and the same most likely happens on ShapeDiver.

However, when I create a rectangle myself and offset it all works as expected.

test

test offset.gh (12.0 KB)

Hi @Pavol,

I am running the following rhino version:
Version 7 SR9 - (7.9.21222.15001, 2021-08-10)

And, the following grasshopper version:
Tuesday, 10 August 2021 15:00 - Build 1.0.0007

When checking for updates, it says my rhino is up to date.

I am not sure if this can help, but I have a private model called b01_PathOffsetOpenCrv_v02t, where the offset is working just fine. It likely uses offset components from ‘a few RH updates ago’.

Cheers
Matteo

Rhino 7 hasn’t been deployed on the main platform yet so this might be the reason for misbehaving components. Could you try opening your model in Rhino 6, save and re-upload again?

I do not have Rhino6, but I gave it a try in Rhino 5.

In fact, the offset component from Rhino 7 fails. If I use a offset component from Rhino 5, it works well. This apply to both Rhino and the Shapediver platform.

Connecting the dots, this offset problem showed up after the last Rhino update.

This is becoming a serious problem for me. I am days away from launching my product, which completely rely on Shapediver service.
The risk of everything falling apart everytime a Rhino update is due, is a bit hard to digest. How can we work toward a solution?

All my models are developed in Rhino7 (at the moment they are 14, and this number is going to increase steadily). It make little sense for me to keep working on RH5 and GH0.9, as they are not being developed anymore.

P.S. on the 27th of July I was told that my shapediver account was ‘updated’ to Rhino 7, and in fact it runs on a different server ever since

@matteo.b we got to the bottom of this. Don’t leave the plane input in the offset component empty. Even though it works locally, it causes troubles on our servers. I hope this resolves the issue and you will successfully launch your product. Let me know if you have any questions.

error_offset SD1.gh (17.6 KB)

2 Likes

Ok. That is an easy fix.

Thank you for your help!