Minor V7 bug

While I can change the layer colour in the Right Sidebar, trying it in the dropdown box on the top bar does not.

Really minor one, in the help files if you click on a blue link a box pops up but it’s about six characters wide, and does not seem to be able to be dragged wider.

I did try one of the Path Animations, It went through the motions, but I couldn’t find the resulting file, though this may be me, I will try it again.

Still loving V7.

Hi -

When I click on the layer on the top bar, a panel flies out showing the list of layers with names, visibility status, lock status, layer color, etc. Clicking on a color swatch pops up the color selector pops up. That is not happening on your machine?

Here, that box is wide enough.

Make sure to use the RecordAnimation command, not the PlayAnimation command.
You will be looking for the individual frames. It looks like the default path is /Users/[you]/Documents/Animation.

Could you run the Rhino SystemInfo command and copy-paste the result here?

Thanks for the swift reply.

On the change layer colour, clicking a colour swatch opens the Select Colour dialogue box (and shuts the dropdown Layer panel) and after selecting a colour and clicking Apply the box shuts, but nothing has changed. The Right Sidebar functions fine.

On the help files, I’d only tried one. I just tried some others and they work fine. The one that functions as I described was the entry for Enter. In it, it has two blue Enter links, they both do it.

I’ve just revisited the Animation and this time had it save the file to Downloads, it worked fine. I guess it worked the first time, but I can’t find it.

While I have your attention. Is it possible to make a SpaceMouse button function as Return? It used to work (V5 and V6) but it now states in the help file (hence I found the funny Enter link) “The Enter command does not repeat the previous command like pressing the [Enter] key does.” am I missing something?

Again, thanks for the reply.

Rhino 7 SR0 2020-11-9 (Rhino 7, 7.0.20314.03002, Git hash:master @ 9d1a3d02b292e00d3480c301d33f414d91acdcbd)
License type: Commercial, build 2020-11-09
License details: Stand-Alone

Apple Intel 64-bit macOS Version 10.16 (Build 20B29) (Physical RAM: 8Gb)
Mac Model Identifier: Macmini8,1
Language: en-GB (MacOS default)

Intel® UHD Graphics 630 (OpenGL ver:4.1 INTEL-16.0.49)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel UHD Graphics 630
Displays: DELL U2415 (94dpi 1x), DELL U2415 (94dpi 1x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
DELL U2415 (1920 x 1200 @ 59Hz)
DELL U2415 (1920 x 1200 @ 59Hz)

USB devices
GenesysLogic: USB3.0 Hub
Maltron: USB Keyboard
3Dconnexion: SpaceMouse Wireless
GenesysLogic: USB2.0 Hub
Apple: Headset
Apple Inc.: Apple T2 Controller

Bluetooth devices
Broadcom: Magic Trackpad 2

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.0.20314.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.0.20314.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.0.20314.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.0.20314.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.0.20314.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.0.20314.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.0.20314.3002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.0.20314.3002

Hello - typing Enter does not do what the enter key or space bar does - I guess it is really only used in macros, but no, it does not repeat a command, and as far as I can see did not in V6 either. I do not know what the 3dx thing does with Enter as a command but it seems at least possible a space could be assigned.



thanks for the reply.

@pascal It definitely used to work, I’ve been using it for the past two years (and still can’t stop my self from instinctively doing it now). It went in two stages, I think after the last update in V6 (about 2 months ago?) some times it would repeat the last action, some times it was the one preceding the last action, I think it had something to do with the way the action is terminated. In V7 it stopped all together. I accept that that’s just the way it’s going to be, it must have been changed for a good reason.

I’ve tried a space, but without luck.

What I find odd is that the 3Dconnexion software allows you to assign text or a key press, Return, Delete, Esc etc. The Mac version of Rhino doesn’t use it, does the Windows version? If not, why are 3Dconnexion adding it to the App, just on autopilot?

The larger version has a dedicated Return button, as no one else has flagged this, I’m assuming this must still work, just a bit of an expensive way of fixing it.

The other thing I use is an iPad App that’s a button board using the keyboard short cuts to activate my most frequently used functions. Unfortunately, with every Rhino release or OS release, another button dies, I need to rewrite it all. Any chance McNeel might like to offer an App like this, though I guess with the current Apple M1 curve ball, you’ve got more than enough on your plate.