Migrating Shapdiver viewer from v2 to v3

I’m following the migration guide for the Viewer from v2 to v3. It works well for sample models as provided in the code snippets but doesn’t work with our setup. Now I narrowed down the issue into one component which might causes the problem.

The TextFileInput component is used in our model and worked well for the last 6 months. Now, when moving to v3 it seems that the input field is not working properly. Since you still provide settings/viewer for v2 I was able to use the input field in the dashboard. This shows clearly that in v2 the file input is working, while in v3 it doesn’t. Please see below.

My model is private but the model name is: Giltek lattice tower v1.2 and the url to that shapediver.com/app/m/giltek-lattice-tower-v1-2

Could you please take a look what is the issue?


  • MacOS Big Sur v11.5.2
  • Rhino Version 7 (7.14.22010.17002, 2022-01-10)
  • Grasshopper 10/01/2022 version

I could reproduce the issue, it seems that the new platform does not support the json extension at the moment. We are working on the issue, in the meantime you could store your json object in a .txt file and parse its contents after importing using the JSON Parse component of the plugin.

Thanks @mathieu1 yes, we can try that :wink: …when do you think the issue to be solved, more or less?

We have not identified where the issue comes from yet so I don’t have an answer at the moment. We do consider with a high-ish priority!

Thank you, fair enough :wink: …in the meantime we work further with the .txt file.