Message window about recovery file is hidden behind "recent file..." menu

Sequence :

  • have a unsaved grasshopper definition file
  • “force quit” grasshopper without saving the definition file
  • start grasshopper
  • File->recent files…
  • select the gh file


  • Message window about recovery file is hidden behind “recent file…” menu
    Software information

Software versions
Rhinoceros version: 5.4 WIP (5E334w)
Rhinoceros path: /Applications/
IronPython version: not installed
WIP expiration: 19 January 2018
Language: en-FR (MacOS default)
macOS version: Version 10.12.6 (Build 16G1036)


Third party kernel extensions
org.virtualbox.kext.VBoxDrv (5.0.16) 35F02C29-8027-3636-ACD2-6F171A50C1D8
org.virtualbox.kext.VBoxUSB (5.0.16) BD2570CD-7993-3635-BE1E-FAB977FFBD5C
org.virtualbox.kext.VBoxNetFlt (5.0.16) 2C1775A7-B7A3-32A2-9E8B-951C1B499870
org.virtualbox.kext.VBoxNetAdp (5.0.16) B108642D-2C95-3CB4-8D0B-01F867E60FBF

Hardware information

Computer hardware
Hardware model: MacBookPro9,1
Processor: Intel Core i7-3615QM CPU @ 2.30GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 512 MB
Memory: 512 MB
Screen size: 1440 x 900
Displays: Color LCD (111dpi 1x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller
Logitech: USB Receiver

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.17.5 355.10.05.45f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Hi Peugeot-

How are you "Force Quit"ting Grasshopper? This step is unclear to me.

With macos, when an application is busy, if you click on the RMB, a menu appears with “Force Quit” (see screen capture below).

  • “force quit” grasshopper without saving the definition file

So, you meant to say “Force Quit” Rhino :wink: Yeah, I tried that initially, but I was not able to reproduce what you’re seeing on my machine. Can anyone else?

“Force Quit” Rhino is a mean to have Rhino exit with an unsaved gh file (my apologizes for missing this step).
Therefore, you need
(1) to have an edited and unsaved gh file in grasshopper (use the enclosed file)
(2) to have a workload with this gh file (for insance a computation that takes several minutes such as the file enclosed. Edit the by setting xCount slider to “10” for instance, the computation takes several minutes).
(3) force quit
(4) restart grasshopper
(5) file–>recent files–> (13.9 KB)

hopes it works that way

Wow, that was tough to reproduce. Thanks for the additional info and the definition. Logged as RH-43941.

16 steps !
That shall qualify as a record for a bug description.