Meshmachine / plankton related questions

Hi all (maybe specifically @DanielPiker and @will ) ,

I found that I could download the newest release of plankton here.
The folder contains Plankton.gha and Plankton.dll, but not PlanktonGH.dll -
I am wondering when the last one is needed and when it is used?
Is it only being used by Kangaroo 1, so isn’t updated anymore?

Regarding MeshMachine, I found the latest source code here,
but not sure where exactly is the newest GHA since it is not in the release tab (and I couldn’t manage to compile what is downloaded from the page).

Thanks a lot,


Hi @timothytai,

  1. “PlanktonGh.dll” is just “Plankton.gha” renamed.
    Visual Studio 2013 made it difficult to reference non-DLLs into a project (such as MeshMachine), so the two ended up getting distributed. Ideally PlanktonGh.dll wouldn’t exist at all. In the case of MeshMachine, I manually edited remesher.csproj to reference the .gha directly…
  2. To compile MeshMachine, drop Plankton.dll and Plankton.gha in the lib/ folder. The RhinoCommon and Grasshopper references are handled by NuGet. If you’re using VS 2017 then these packages will be restored automatically when you start the build.
1 Like

hi @will, thanks a lot; will report back if i have any additional question.

1 Like

hi all @will,and @daniel,
I have the same question that cant load the plantkongh.dll. so how can to fix it.
may be i renamed the plankton.gha to …dll?or just drop gha file into the libs folders.
i am really puzzled .
thanks a lot,

Hi, I tried to install Plankton/Mesh Machine per the instructions above and no luck. I spent some time on it, unblocked files etc. If someone has clear directions and links, I would really appreciate it. I’m running Rhino 6.

Also, where would it show up when installed, Kangaroo or GH mesh or WB?


hi, did your problem be solved?
actually I have the Plankton.dll and Plankton.gha file by generating the sln file.
If you need I can send them here

Hi, no I never resolved this, tried all I could and gave up. If you have the files that work please post thx for the help!

Hey @connie, have you tried the SimpleMesh and RemeshByColour that @DanielPiker added to Kangaroo2? Make sure you’ve got that latest version of Rhino 6 and you should find them under Kangaroo2 / Mesh. (Kangaroo2 is pre-installed in Rhino 6.)

Does SimpleRemesh replace MeshMachine (compatible with Kangaroo 1?) or the Mesh > Cocoon > Refine component?

I’m running into an issue using the Cocoon Refine component and have arrived here through getting the following error:

  1. Solution exception:Could not load file or assembly ‘Plankton, Version=, Culture=neutral, PublicKeyToken=null’ or one of its dependencies.

These posts are how I got here:

Also, I’m running Rhino v6 on Mac Catalina.

I solved my own question regarding the error by manually downloading and installing the Plankton version from Github.

1 Like