Meshing never ends

Hi, everyone

I really need help with this.
I have modeled this footwear sole with texturesfor 3D print, apparently the model is fine but when trying to export to OBJ or STL it never finishes,even after hours of waiting.

Also I have tried creating the meshes before exporting and it does not finish doing it either. I have tried to split the model into 2 before exporting but the boolean operation does not finish either.

file is 575 Mb

this is my systeminfo
Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

any advice? :c

Are you able to view the model shaded? The question is, is this just a case of a horrendously complex model,
or is there “bad” geometry messing up meshing? Does SelBadObjects find anything?

You left out the info on which version of Rhino you’re using. Also a .3dm file goes a long way toward getting answers you can use.

thanks for replying
I run the SelBadObjects and found 1 surface that was good prior to a boleean that I tought was the one that corrupted the model but except for that now the closed object is fine according to the same parameter.

But still can’t render shades in viewport or convert to mesh or export to STL.

I actually using the Rhino 7

Hi @user352,

Anyway we can see your 3dm file? Feel free to send me a pm if needed.

– Dale

How many thousands of surfaces are in your model? Are you using anything like displacement that will send meshing through the roof?

It’s got to be possible to turn the mesh settings down to a level where it works, then build up from there. Go to the custom settings and set Density to 0, max aspect ratio to 0, minimum edge length to something relatively big for your model, and turn ON jagged seams(which will need to be turned on to get a wateright mesh, but we’re trying to see something at all…)