Meshing jagged for ruled surface

render_meshing.3dm (241.0 KB)

The surface is generated from a Sweep2
I’ve changed the setting to slow and smooth in options but still get this.
Is there anything I can do to smooth this out even more? It’s a relatively simple geometry…

Set maximum aspect ratio to 1.0.

You can also set the custom render mesh per object in Properties…

1 Like

I did that too, but for me the aspect ratio needed to be on 1.0 with the rest of the settings untouched (on the Mac). I see you have a maximum edge length instead.

For fun I added Thickness, amount 5.0, solid and both sides enabled. Instant art (need to zoom out quite a bit)

from my geometry!? this is wild.
are there documentation on what those meshing parameters mean? in other words why did i have to change an “aspect ratio” to make it work?

https://docs.mcneel.com/rhino/6/help/en-us/index.htm#popup_moreinformation/polygon_mesh_detailed_options.htm

There was another recent post on the same subject, the answer is that the Rhino mesher’s standard settings simply do not handle long, skinny UV structures well… Hence setting an aspect ratio or a max edge length to force the skinny triangles to subdivide…

Perhaps a slight digression, but if you use the curvature line parametrization to generate the helicoid, the mesh looks fine even with the default settings



helicoid_parametrization.3dm (376.5 KB)

Very interesting…Is that a toggle option in Sweep2? How do i sweep using the curvature line parameters?

I modelled it with an equation in Grasshopper.
This parametrization might look a bit unfamiliar at first when you see a full patch, but when you trim it with a cylinder it becomes clearer that it’s just the same surface as the more usual version with the isocurves on helices and straight lines.
The nice thing about using this form for meshes is that all the faces are planar (and I think this is why the default render mesh works well with the NURBS form of this).


helicoidcurvature.gh (6.6 KB)

1 Like