Mesher ignores "max edge length"


#1

… like the tile says, no way to avoid long polygons.

Regards,
Micha

MaxEdgeLength.3dm (188.5 KB)


#2

Is this an extrusion? If so, this is a known “bug”… Convert it to a polysurface with ConvertExtrusions and see if it doesn’t behave better…

–Mitch


#3

Hi Micha,
This happen because the simple plane options.
If you switch off this option it works.
Cheers


#4

Thank you for the workaround Skysurfer.

I hope it will be fixed so that this option works for all polygons that are part of non “simple planes”, because the intent of the “max edge length” is to avoid long polygons.


#5

Interesting is too, that “simple planes” is ignored in this case, the ground plane and the sides of the “wagon” are still devided. The mesher works quite chaotic.


#6

you have to click on ‘Preview’ after switching on simple planes (or changing any setting), to update the preview.


#7

I used the preview button,also I pressed “OK” and checked the mesh later - always the same.


#8

weird, this is what i see with simple planes turned on:


#9

Looks like Micha is still using V4. Am I wrong?
Or it’s just the old interface?!?


#10

I use Rhino 5 64, but I use the old XP design for my Win7. :smile:

Here my file where the simple planes doesn’t work. MaxEdgeLength 001.3dm (271.4 KB)


(Pascal Golay) #11

This is definitely badly broken, I’ll send it to the developers for a look- thanks.

-Pascal