Mesh vertice points are wrong

hello
i was trying to connect mesh vertice points to some other points and was getting funny lines. so i checked and realized vertex point list numbers are wrong as seen in the picture. if i use the same shape as a surface this problem disappears and numbers and lines are correct.

what may be the reason ?

Hi :slight_smile:

It’s not necessarily wrong. The vertices of a mesh does not have to be in geometric order. What do you mean by funny lines?

what i wanted was “pramid” like diagonals between vertices and polygon centers instead i got what is in the picture

Umut, the most simple way to do this is with Weaverbird.

The Stellate component add a pyramid on every mesh face.

In case that doesn’t work for you, post a Rhino file and Grasshopper definition with the relevant inputs.

i will share an example of desired vs what i got


this desires result i can obtain by using surface commands instead of mesh. because surface vertices are “in order”

pic i shared before is the obtained result from mesh

this pic is obtained by surface usage

If you want help, please post your files instead of just screenshots.

FULL_OTOMASYON_UZAY_2.gh (23.6 KB)

here is the file with internalised surface and mesh

I don’t use Pufferfish so I can’t see what you’re trying to solve with some of the components.

You can use Extrude to Point to create the pyramids.

FULL_OTOMASYON_UZAY_2.gh (22.1 KB)

1 Like

thanks martin, i tried your solution on the mesh side of the code and it worked