Mesh trim failed


I have a problem with trimming a mesh. I need to trim some parts from the mesh (with curve or brep), but it gives me really strange broken mesh. I tried some procedures with check mesh and repair mesh, but “repair mesh” command gave me just many “good meshes” but exploded to individual pieces and i wasn’t able to join them again into correct mesh. I guess I am doing something wrong, because I am beginner with meshes. I just need to work with this object, so it could be mesh or NURBs object as well.

mesh trim.3dm (494.3 KB)

I appreciate every reply!

Hi Petr - there are a number of vertices that are slightly off from their
neighbors. Try: AlignMeshVertices first, I used a distance of .1 and it
seems to have worked. Then MeshSplit…

Hi Petr- Check tells me there are a lot of self intersections - you can clean up with AlignMeshVertices (I used a distance of .1) and then MeshSplit.


1 Like

Hi Pascal,
great! It works :slight_smile: Thank you very much.

Have a nice day (or an evening)