Mesh transfer problem

Hello,

What is this error message please?
Note that these meshes are the result of a simulation, and that all the meshes have been transferred out of the index 2 mesh.

RIR error|690x264

Tahnk you!

We recently updated the software with some fixes on the meshes side.

Does it fix your problem here?
If not could you please share one of those meshes?

Thanks.

Hello Kike,

Thank you for your answer !
No the problem has not been fixed :confused: and here is an explanation:

At the very beginning there was the invalid mesh issue and I think this is the cause of the whole problem. My first question would be, why do I get an invalid mesh?

I solved this with rebuild mesh from pufferfish but then with RIR with directshape to see if it works, it didn’t work again.
In the end, It worked with a different mesh but I wanted to know the cause of the invalid mesh to avoid this problem next time :slight_smile:


And here is all the meshes without rebuild, which will certainly present the problem in different axes.

Thank you for your time.

Hi @Anane,

We updated again with more fixes for meshes.
Now it highlights the mesh short edges, and tries to collapse those edges before transfer to Revit. With this model you may feel it slow since it needs to fix all those edges before transfer. But if the mesh had no such tiny guys it should be faster than before.

When the object is a bad object it will show you that bounding box, the geometry will not transfer and the component will turn red.

You can use MeshRepair command to heal it.

This change is still on the Daily Builds channel, so if you want to test it please change your update channle from here.

Got it, thanks a lot for your time!

Good luck with your work :slight_smile: