Mesh Scale


#1

Hi There,

I’m running into a funny problem;

I prepared a mesh model for 3d printing, quite a complex model, a lot of detail, etc… I manually had to fix some naked/non-manifold edges, which worked out nicely, now I´ve got a nice mesh, but also one problem: I meshed the whole thing in my modeling scale (1:1 drawn in cm), the 3d print is going to be 1:100. So basically i need to transform the model only by 1/10 (100cm (drawing units) = 10mm (when opening the stl as mm)). Scaling the model up or down I always get problems with my mesh edges again (non-manifold edges), I guess because of tolerance issues. Moving the model into Netfabb I can scale it (I guess netfab doesnt work with “real” units), but somehow I`m reluctant to do that, because I dont really know what happens with the mesh in netfab. So basically I just need to take a zero away from my model scale, but without actually changing its size…Any ideas on that?

Best,
Klaus


#2

That doesn’t make a lot of sense - you ARE changing its size. Every dimension will be 1/10 of what it was, and you are going to produce a 3D physical model from your file. Scaling down probably won’t produce a lot of naked edges - as you are under the file tolerances - but you may get degenerate triangles which have edges that are now also too small (smaller than the file tolerance); some of that may show up as non-manifold…

One thing to try maybe is to first change the file tolerance to 1/10 of what it is then do your scale… However, triangles will still be physically 1/10 of their original size. Whether your 3D printer software can deal with that or not, I can’t say.

–Mitch


#3

Maybe resize it and change in export settings the Maximum distance, edge to surface to 0.01 or something so your exported stl will be in higher resolution and maybe the problem will be solved.