Mesh Machine error

Hello everyone,

I am trying to smooth the circles located on the arches using mesh machine in order to create a relaxed mesh.
The mesh machine components seems to have an error when it is not running and when is running it does not seem to do anything.
Anyone know how to fix this?

Alexandros (4.2 KB)
Vault.3dm (247.2 KB)

When remeshing surfaces with naked edges, you need to set some boundary curves to keep fixed.
I had a go using the remesher in the latest Kangaroo: (67.6 KB)

Those hemispherical indentations still cause a bit of a problem though - do you need the mesh to capture these details?

Hello Daniel,

Thank you very much for your reply.
Yes the concept is to recreate the internal of an arch building with all those circles shaping an organic arch.
Even if the circles are merged with the arch using boolean it does not resolve this?

I tried setting fixed curves as you suggested but now I get a different error and still no result when enabling the mesh machine.

Are you looking for a mesh with fairly uniform sized triangles or varying?
I think to capture those small indentations you’d need quite small triangles there, which will mean quite a heavy mesh if applied uniformly to the whole thing

Ideally those spheres along the arch would be way more in order to get a nice organic surface.
I understand too small triangles will make a very heavy mesh so I wouldn’t mind having larger ones as long as the final surface does not get too stretched.