This is a solid. When I run the MergeAllFaces I get a display that shows some faces gone. What!

MergeProblem.3dm (709.1 KB)

Displays fine on Win Rhino. Try this - Explode it (or use ExtractSrf Copy=No), delete the “missing/extracted” face and use Cap.

Should solve your issue

looking at it a bit more… you have more issues that caused that the display issue. If you look at the image below you have co-planar surfaces on top of each other. The model does not know how to display the proper surface normals (FYI I set my backface color to red and frontface color to layer… that is why there are 2 colors in the image) which is why you have the issue. Eliminate the overlapping surfaces and your issue should be resolved

I had set up face colors in the beginning but lost the settings in reinstalls. I should probably set that up again. Is s this the means you use to discover such dicremepencies?

Also, I’m not sure where the imgage you sent is located. I did the first rec extracting the face and capping but the problem persists.

I use it more often for modeling. The direction of the surface normals is critical for when I do continuous 5axis machining and the backface color lets me determine that easily.

The surface you extracted is the one that is problematic as well as the one “above” it

Aha! I’d noodled around untiil I discovered the face of both those sides extended up into the internal area of the solid. I extracted like you advised, duplicated an edge and used it to trim both sides. It then booleaned back together just fine. What I’m wondering is how does one end up with internal surfaces like this.

There are a few reasons on how they are possible but I cannot determine what you did to to produce them… I would need a detailed ledger of all the steps you took to make the model or you record your screen.

My guess is it has something to do with your boolean operations but I am not positive

I have on occasion been notified that tolerance had to be doubled to complete a boolean operation. I’ve gone back and remade all the parts. But there’s still a fail. I run intersect to see where things are taking place, but the lines produced don’t show me anything I can recognize as significant.

I’ve attached a file with all the elements used to create the various components if you’re interested.

I’m advised to use more trim and split operations to get to the end but often that’s rather tiresome. (849.0 KB)

Where is the original model that you included in this post??! This looks completely different.

The increase of the boolean tol. is most likely due to your coplanar faces and it is trying to determine the proper intersection.

You can always break your model down into smaller parts to make the boolean operations perform better/ determine what part of the model is truly giving you issues.

Split and trim are tried and true - I use them all the time. Yea its a pain when booleans do not work but I know when I do it with split and trim I will end up with the end geometry I want and any issues that persist or develop are my own fault. Its the best way to know all the ins and outs of the model and find issues in your modeling techniques so that you can improve them. It also teaches you how to problem solve and try to figure out other solutions to make Rhino do your bidding; you’re not relying on a background process to do your work. Once you understand how to do it manually, it is much easier to predict how it will behave automagically. And when the automagic option fails you know how to fix it and do it yourself

I must admit at this point that split and trim are more like slogans to me than actual practice. I of course can split and trim curves and surfaces, but what I run into with more complex components is the bit I want to trim away for instance is obscured by an overlapping surface. Is this a process of duplicating egges and then using them to trim with? I try to make my original geometry clean enought to rely on it later for complex operations. So far I’ve come close, but in time there’s always something that fails. I suppose I must go back to the basics but I lose patience.

The model I attached is the same model - just the latest version with whatever changes were made since the last communication. I never wait to proceed, and incorporate whatever kind advice I get whan I get it. It’s no waste of time in my opinion to continue doing difficult things.

I am getting a sense of what to expect, but there’s still moments when I throw up my hands.:slight_smile:

So here then is another boolean issue. Despite the care taken to make it happy, it still won’t behave. My question is does one actually have to explode the model and take each union one at a time? Really? After all that modeling one has too turn everything back into single surfaces and of course run into the trimmed surface limitations.

TrimSplit.3dm (723.6 KB)

Then after going through all that’s required to make the solid, I’m left with a naked edge in a place that was perfectly sound before exploding.

What utter nonesense! Surely I’m mistaken as usual and there’s an elegant way to solve this issue?


Okay, so I extracted a surface and replaced it. Done. Jeez…

It’s due to all of your partial co-planar surfaces… the algorithm has a hard time determining which surface to keep and which one not to. See The attached file - The cyan surfaces are your coplanar surfaces that are giving you problems. If you pushed those faces into the other model a bit then booleanUnion would work better. That being said I went through the exercise of joining the solids together manually and it took me 5 minutes. To me thats time worth being spent. Remember booleans are the easy way out, its not necessarily the best method to use.

TrimSplit.3dm (660.4 KB)

The naked edge issue you found after running split/trim could be due to you having some “odd” surfaces. I personally break up planar surfaces from non planar surfaces (ExtractIsocurve (turn on Knot and Quad snaps) and then use Split). I do this to create “cleaner” models for when I go to toolpath them and it also makes modifying the model easier. If you notice in the model attached below, some faces could be combined to make a larger planar surfaces and a lot of your fillets were part of a single surface.

TrimSplit complete.3dm (930.2 KB)

Try using Wireframe mode with Isocurves visible.

So one should probably make a point of splitting surfaces to seperate flats and curved and then later joini them or rather keep them seperate until one does a boolean op? I ofther use the fillet tool on solids. This would indicate addtional steps on each part.

  • David, thanks that’s of course sound advice for the muddeled sort I become.

That made me bust out laughing! :smile:

I make a point to because it helps my workflow and keeps everything clean. Depending on what your end goal is, you do not have to but I would recommend it.

The filletEdge tool breaks the fillet out as an individual surface when you explode the model. Do a quick test… draw a cube use the fillet edge command and then explode it, you should see its now made up of 7 surfaces.

The only time I have seen the fillets become part of the primitive surface is when the surface is derived from a joined curve (ie. Loft, ExtrudeCrv). Personally, I am not a big fan of this but have to wait for the powers to be to fix it

Well, today was a better day. I actually like what I managed to make.

Thank you guys!

I took the advice and exploded complex forms and pieced them back together. I realized I could simply hide portions until I needed them to join and thereby see the other parts. When I’d thought I’d finished, I checked for edges and a couple naked ones existed inside the form! Luckily I was able to remedy the problem with the cap command.

I also gained some nice blending on advice from David. I thought I’d share that portion and ask about something else; that is when rendered the model still shows construction lines that I thought would not display. Is there some setting that needs to be modified. I’ve no experience with rendering yet. (1.1 MB)

1 Like

Those are not curves but surface edges. The default rendered display mode does not show surface edges, so that is something that you have changed (and can change back).

It does, of course, show something interesting: there should be surface edges at the red arrow as well. There aren’t because the surfaces extend into the surface behind. Not a good thing.