Merge all edges doesn't work :(

Hey all, this happens also quite often, as a workaround when cap surfaces won’t work I need to loft the missing surface and run the simplify planar faces macro by @Helvetosaur Macro to change a lofted coplanar surface into a trimmed plane?

any ideas why the command won’t apply here?

Hi Hannes - can you post that surface?


maybe the edges are not colinear?

1 Like

The MergeAllEdges command does not merge edges across kinks.
Kinks are explained here:

1 Like

@pascal @DiegoKrause & @andrew.nowicki thanks for clarifying, have to check this!!! Thank you!

I am also noticing an issue with ‘Merge All Edges’ not working. I have a very simple mass that came from a city file, but it is very clean and everything appears to be rectilinear and straight, but still I can’t get rid of the kinks on some of the straight edges.

I noticed the problem when I was trying to scale from the bottom midface and the midpoint appeared to be off by a little. No matter what I try I cannot get rid of the kink along the bottom edge without manually rebuilding the geometry.

Using ‘Solid Point On’ I can’t see any vertices for the kink, but you can see in the attached image that when I ‘Dup Edges’ and turn on points for curves there are vertices for all the kinks. If I run a ‘Simply Curve’ on those it gets rid of all the kinks. I thought ‘Merge All Edges’ should have the same effect, and it always has for me, but this one will not fix for some reason??

Merge All Edges not working.3dm (208.1 KB)

Hello - this bug track item may help -

In short, merging edges is currently not exactly the inverse of splitting edges - the resulting edges still have fully multiple knots at the joins.


Ok, thanks for checking on it. I just extracted and rebuilt those faces and it’s fine now.

Hello - DupBorder, SimplifyCrv on the results, UntrimAll and retrim is a way to get what I think you want.


1 Like