McNeel Update Service is unavailable

Hello everyone,

I need to update my Rhino to version 7.3 in order to get the latest version of Vray.

However, I get “The Mcneel Update Service is Unavailable” warning (as in image) .I have Rhino 7, 7.2.21012.1100.

I checked the Service settings from windows. Mcneel is running, and I tried to restart it.

I repaired and modified Rhino from the control panel. I remembered unchecking those two boxes probably when I am installing. I checked them and did the modify.

Still nothing is changed. I have the same problem.

What else I can do more?

Thank you!


I would just download the latest SR (7.6) from the main site and install that.

Hallo, ich habe das gleiche Problem mit SR33. Nach dem installieren von SR33 steht die Fehlermeldung bei mir immer noch dort.

Rhino 7 SR33, McNeel Update Service

Hi Markus -

That appears to happen once in a while on some machines. Most of the time, installing a new SR will get this to work again. In your case, SR33 is the latest though.

Have you tried repairing the Rhino installation in the Windows control panel?
Have you tried restarting the “McNeelUpdate” service from the Windows Task Manager?



Hi Markus,

Can you please uninstall Rhino 7.33 and reinstall it, and see if that fixes it?