McNeel Update Service is unavailable

2020-05-28 17_38_23-Window
I tried to unistall and reinstall, repair … nothing.
Service is active and running, but the whole section is greyed out.

(Actually I just want to try latest service release candidate, there are esternal downloads for that?)

Any ideas to fix this?

In Windows Services,
is McNeel Update Service 5.0 set to Automatic and Running?

Also, on firewall nothing is blocking rhino related stuff…

In Options > Updates and Statistics, if you click on the blue Check Now… link, does that work?

Can you change the Update frequency menu from Service Release to Service Release Candidate?

I can’t click anything at all.

Can you please

  1. Open the Event Viewer
  2. Browse to Applications and Services Logs
  3. Right-click McNeel, then click “Save All Events As…” and save a .EVTX file.
  4. Zip the EVTX file
  5. Send me the EVTX file in a direct message


Thanks for the details. Your event log is showing the error
“Error,Internet access is disabled. McNeel Update Service will not start.”

I’ve seen this before, and am logging it as:

From your link i’ve installed 6.27.
I tried something differend, enabling this 2 flags:
2020-05-29 14_18_35-
“Let Rhino automatically download latest versions”
“Send anonymous stats about installation to McNeel”

I’ve always un-checked those in past, and update service was always working fine… :man_shrugging:t4:

Anyway, installed with those 2 checked, now update service is on and ready inside rhino options.

I just checked and found I have a similiar issue with Rhino in the Simplified Chinese. It’s probably a i18n-related bug.

Hi, so is there a way to get the update checker back-up and running again without doing a complete reinstall? I’m also experiencing a full greyed out section and probably might have disabled “Let Rhino automatically download latest versions” option during the original install. McNeel Update Service seems to be up and running in the task manager services. Thanks for the help!

edit: I’m here also because I would like to install the GL Studio plug-in. It’s installer is throwing me an error about using the most updated SR pack. Thanks again!

System Info Below;

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Educational, build 2020-03-19
License details: Cloud Zoo. In use by: Berkhan Eminsoy ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-0FRHM9N4

Hybrid graphics system.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-8-2020 (M-D-Y).
Primary OpenGL: NVIDIA Quadro M2200 (NVidia) Memory: 4GB, Driver date: 6-5-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 443.32

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-5-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Users\bemin\Google Drive\Columbia University\GSAPP\DESIGN RESOURCES\SOFTWARE RESOURCES\Rhino\Grasshopper\Plug-Ins\elefront400\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

you can always go help>check for updates.

also read this as you have a hybrid laptop-

@theoutside yea no the whole screen is greyed out, can not press any button. And thanks for the graphics advice, I’ll double check to see if I’ve implemented that change! See below… Does this mean I have to reinstall?

edit : also if I download the latest SR installer and install that, will auto-update the current install of Rhino6? Thank you!

Hello - the latest is 6.29 - from here:

I’d install that if you do not have it and see if it sorts things out for the updates page.