Materials missing

Materials are missing in V7 on my laptop. I cannot open the Materials panel. The Materials command executes but nothing happens. Materials is on the list of panels which opens when the “gear” icon is clicked. Is there a setting which needs to be altered? Any other suggestions? Example file from the laptop: NoMaterialsDC01.3dm (2.1 MB) Materials are present in V6 and V8 WIP on my laptop and on my desktop which is running the same version of V7.

Added: The materials column is visible in the Layers panel but I can’t do anything with it.

Rhino 7 SR5 2021-4-6 (Rhino 7, 7.5.21096.11001, Git hash:master @ 4cd1d638a2f2d3bb193441ecfc1e54559d092807)
License type: Commercial, build 2021-04-06
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 12Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 11-4-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 860M (NVidia) Memory: 2GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version: 27.21.14.5671
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\ClippingBox (4dfff1df-5f09-43ae-a044-77b115244b02)\1.0.0.0\Rhino 6\ClippingBox.rhp “ClippingBox” 1.0.0.0
C:\Users\David Cockey\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ColorPicker\6.0.0\ColorPicker.rhp “ColorPicker”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21096.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21096.11001
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21096.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21096.11001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\David Cockey\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Users\David Cockey\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2020.12.7.446\SectionTools.rhp “SectionTools”

Solved: I had disabled the Render Development Kit UI. Enabling it and restarting Rhino solved the problem. Wild goose chase of the morning but the goose was caught.

It is not obvious that a plug-in which has “Development Kit” in it’s name is needed for a core Rhino function.

Hi David -

Just wondering - did you actively disable that yourself, and, if so, what problem did you solve doing that?
-wim

Materials are things for rendering.

Anything rendering related is built on the RDK: materials, textures, environments, rendering panel, render engine integration, etc.

I disabled the Render Development Kit UI plugin (along with numerous other plugins) when I was diagnosing the reason my computer was very sluggish. It turned out to be Windows updating related, nor Rhino related. I didn’t re-enable it since I’m not during any development of rendering capability.

I understand that materials are things for rendering. That is how I found the problem.

It is probably a matter of semantics but my assumption was that a “development kit” is for use by a software developer and not something that is needed to execute released software.