Materials in rendered view display as transparent

Hi all,

I’m using rhino 6 and recently when I apply materials to objects and switch to rendered view, the objects with applied materials show are semi transparent.

Hello - does a full rendering work as expected? (Render command). Are the materials ones that ship with Rhino?

Yes, it does, just checked. Also, the materials that come with Rhino are semi-transparent too.

Hello - can you please run the SystemInfo command in Rhino and post the results?


Rhino 6 SR20 2019-11-18 (Rhino 6, 6.20.19322.20361, Git hash:master @ f60ce76e397bba419469ae5277fc1578641caa3a)
License type: Educational, build 2019-11-18
License details: Cloud Zoo. In use by: loganh96 ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-TLI3GC2

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 9-14-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 11-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.20

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-6-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.20.19322.20361
C:\Users\logan\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 0.0.19316.1331
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - I don’t expect this to have anything to do with anything you are seeing but just to eliminate the variable, can you please temporarily disable Enscape in Options > Plug-ins page and then restart Rhino and see if that makes any difference?


Unfortunately, that didn’t do the trick.

OK - can you also try un-checking the Alpha Transparency setting in one of the materials?


That didn’t work either. Do you think I’ll have to reinstall rhino 6?

Hello - I doubt it… let me ask some bigger brains…

@loganh96 one other thing - are the objects’ normals pointing outward? (Dir command)

aannnd, @loganh96 - I’m scratching the bottom of the barrel but there is another thing to try: In Options > View > Display moded > Rendered, please click on Restore Defaults…
@loganh96 - sorry to pester - before I ask the devs, I’d like to be sure you are using the default Rendered mode - they will want to know this.Thanks.


Yes all the normals are pointing outward.

I appreciate all the troubleshooting! I restored defaults to the Rendered mode and it’s the same.

Thanks, I’ve asked the larger brains - meanwhile, does this happen with any material, like a new solid color (no textures) ?


It oddly doesn’t happen to the default material, but to all new materials applied.

@loganh96 - it looks like this is fixed… in V7 at least, but you can try nudging the transparency slider off of zero and back again on these materials - does that sort it out?


1 Like

That fixes it, all the materials are fine after that; thanks! But it seems like I’ll have to do that for every new project that I start, right? Not too big of a deal but have you found others to ask about this problem?

Hello - yeah, I know it is not a great solution - it will be fixed in V6 as well, just not in a public release for a while I guess. The developer says you can try, as a sort of shortcut, selecting objects that re not showing the problem and then move the view - that might sort it out for that session at least.


Alright, I appreciate the help, thanks guys.

Great to hear this is fixed. I get this from time to time as well, and my solution is just do go in and re-assign materials which also fixes it (until it appears again).

I recently upgraded to Rhino 6 and Vray Next.
I’ve been experiencing the same issue as Logan.
When Enscape is disabled in plugins, the problem goes away for me.
It only happens to materials created in Vray and does not exhibit in any defualt materials.

Is there an incompatibility between these software updates? (Enscape/Vray/Rhino6)
Is there something I need to turn off or on somewhere in settings? Or something I just need to work around until V7?

I have posted to the Chaos Group Forum about this too as I feel it might be a Vray issue rather that a Rhino one.

Any help much appreciated.