Material Panel Samples saturate CPU


Im encountering an abnormal problem of speed when ifm affecting materials to layers of my scene.
Trying to see with you if there is a way to solve it with some settings.

When im reaching a certain numbers of material in a scene (around 10) Everytime im opening the material panel or the list of material in Rhino, Samples seem to take much time to display and this is almost blocking my computer, sturating the CPU (see screenshot attached).

My CPU though is a brand new AMD Ryzen Threadripper 7980X 64-Cores

Does someone have an idea about this?
Below , my System info.


Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commerciale, build 2024-04-10
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 256GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 4090 (NVidia) Memory: 24GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0
- Secondary monitor attached to adapter port 1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 24564 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

I think this is… normal behaviour, apparently.

I think many have just changed to the tree view, given the usefulness of the previews seems limited anyway. This stops the constant sample re-rendering.

1 Like

Ok :slight_smile: that is a step.

Thanks you.

i dont see much performance improvement, yet it appears it does not flickr (rerendering the preview spheres) it still impacts the performance dramatically, at least on mac that becomes devastatingly slow to work with having many materials in the file.

i basically never touch that panel if i dont have to

Tools > Options > Advanced, search for PreviewSamples. Set to 10 or so. Furthermore in Rhino Render bump viewport sharpness one step to the left. Or two. This affects the resolution used to raytrace. More to the left means larger pixels (blockier) for viewport and previews.

Btw, do you have VRay set as your current renderer? If so then the above suggestions don’t matter

Yes is is set as my current renderer.

Do the CPU spikes still happen when you set Rhino Render as the current renderer?

It happen with AND without Vray Set as current renderer

Just as an extra test, does it still happen with also the V-Ray plug-in disabled?

Tomorrow we should have 8.7 service release out, meaning 8.8 service release candidate will be available as well. Please try tomorrow updating to that (Help > Check For Updates… - set Update Frequency to Service Release Candidate and click Check Now… to get the link to the latest service release candidate).

Yeah it still happens.