Material and Texture Mapping

I’ve been applying a standard textile material which has been working pretty well for my current purposes. I’ve just discovered that when I rotate the object to which it is applied, the map does not rotate with it, and now the pinstripes I’ve been using are all mapping in the wrong direction. Is there a box I’m supposed to be checking to ensure the material and its direction are tied to the orientation of the object?

Thanks for the help,

Michael D

Hi Michael - the texture is no doubt set to use ‘WCS/OCS’

  • in that case, before rotating the object, use ApplyOCSMapping (= ObjectCoordinateSystem) and set the desired direction by three points (sets a plane) This will then travel with the object.

-Pascal

Thanks Pascal.

mD

Rhino documentation does not mention ApplyOCSMapping.

The “WCS/OCS” and " WCS/OCS (box style)" labels are confusing. I would prefer “World Coordinate System” and “Object Coordinate System.”

Rhino documentation is also confusing. It is posted here: Textures | Rhino 3-D modeling

Added now.

1 Like

There is no update in Chrome browser - no ‘ApplyOcsMapping’ words in documentation except menu item shown in the following screenshot. I used F12 followed by ‘Empty Cache and Hard Reload’ - it did not help.

Thanks for checking, but it works for me.

Try open Texture mapping | Rhino 3-D modeling and use “Empty Cache and Hard Reload”. And then the ApplyOcsMapping item in TOC should work.

It does not work in Chrome browser and Brave browser, but it works in Firefox browser. I have downloaded Rhino 7 Offline Help from Rhino - Download - Rhino 7 Offline Help - it works fine. (By the way, your applyocsmapping.gif looks nice.)

Is it possible to remove the OCS mapping? Or maybe every other mapping is WCS mapping? I have old graphics card (Nvidia Quadro K2000M), so I use ‘Legacy Rhino Render’. On my laptop all textures move with the objects, so the ApplyOcsMapping command makes no difference - it does not change anything.

I have no idea. It will finally get updated later.

Thanks, I will redo the clip to include move and rotate based on Pascal’s suggestion.
I’ll use mp4 for this one because GIF will make a huge file size.

Yes, from here:
(If it does not work, try again in the next public build.)
image

Look into the texture mapping setting. It is set to Mapping Channel 1 by default. ApplyOcsMapping only makes difference with WCS/OCS and WCS/OCS (box style). I guess this is the problem.

1 Like

The Legacy Rhino Render does not know about the OCS mapping. To see the mapping properly you’ll have to use Rhino Render.

2 Likes

At a risk of being completely off-topic, is there a way to modify WCS mapping? By default it uses model X,Y and Z coordinates, but is there any way to rotate it to match a Named Cplane?

Or alternatively are there any “Named OCS” mappings? I’ve seen Mapping Table mentioned in documentation, but I couldn’t find a global list of Mappings - all other than WCS seem to be local to the objects, that is one object = one mapping (every object has a separate mapping).

Sorry, no. World Coordinate System is static, so WCS mapping cannot be changed.

No, but you can use “Match Mapping” to copy OCS mapping from an object to another.
image