Match surface issue

I lofted a surface horizontally and then matched the upper edge to an arc. I then ran a surface fillet on it with some vertical surfaces.

Afterwards, it seems the originally matched surface edge is now off. I can rematch with a trimmed surface so I’m wondering what one does to accomodate this.

MatchSurface.3dm (654.7 KB)



Are you looking at the edges, or at the render mesh only?


I’m judging by the render mesh. Is that the problem?

The mesh is set to smooth and slower. Even cranking up the mesh in zebra still shows a problem

Further work on this and a few more things:

The lofting creates an undercut on the upper edge of the surface. It also makes an arced edge that must be matched to join

Next step:

Running match surface returned edges that could not be joined.

I then split the lofted surface,shrunk it, and did the same thing with the proxy surface so the edges where the same length.

Yet even after that a match surface will not actually match the surfaces.

MatchedSurf.3dm (239.0 KB)

Hi James - you can use InsertKnot > Automatic a couple of times to geive the surface enough points to Join after MatchSrf, or, use Refine in the MatchSrf settings, but I find that rends to over do the knot insertion.


I changed degree hoping that would do it.

But no go. Then I did the refine match

That finally made it work.

But then the extra points.