Mar 8 WIP change log server error

Around 8:40AM EST the change log link on the download page produced a 503 server error. Download proceeded OK.

@brian @pascal

Further update: ~2:30 PM EST now neither the change log nor the download page (the one that actually downloads with the language request button) work. Times out with “server error” message.

The reason I’m trying again is because the download I got this morning won’t start after installation. Something about an MS “api-something” file missing.

March 1 WIP installed and started OK.

What if you try through the check for updates dialog in the Rhino Options?

Good point, Wim. My method is to click the link in the “Welcome to Serengeti” page and proceed from there. I just checked for the change log again and still get the error (~8:00 PM EST)

Come to find out there was nothing wrong with the download after all. I found the missing file at MS, downloaded and installed it and the WIP worked normally. @brian If this is a transition issue with Win 7 & 8 & 8.1 users not having the latest updates, maybe it would be helpful if the error message (or just a note on the download page) warned the user about it and reassured them it’s OK to download and install the file. Maybe a link to the MS page. Perhaps the installer could check for it? - at least for a while until everyone has updated or switched to Win 10.

From reading the MS description, I gather that this is a recent addition to the Windows installations to accommodate an app’s use of Windows Universal code. Has McNeel started using some of this code with the latest WIP? (In other words, why hasn’t this surfaced before?)

3/10/16 ~11:00 AM EST: Download link now works, but change log link still doesn’t.
That’s the links on this page: