Mapping imported meshes


#1

Hello,

I’ve come across a problem when trying to assign mapping coords to an imported mesh. If I create a mesh or extract a mesh from a Rhino object I have no problems assigning say a planar mapping and the material with the map renders fine.
However, when I import a mesh from another app in say 3ds format and I apply the same material after I assign the same planar coords, the object doesn’t render the map. I can make visible the mapping widget but the bitmap doesn’t render. I never had to do that because I usually either create the objects in rhino or I merge a mesh object which has been extracted from a Rhino object. So after using Rhino for years, it is the first time that happens. I tried flipping the normals and also rebuilding them.
Is this a known problem or is there some other thing I need to do?
Your help would be appreciated.


#2

I had a problem like this - I imported a mesh, but the added Rhino mapping was ignored. For me it helps to export/import the mesh (from within Rhino) as OBJ again.


#3

Thanks Micha, it didn’t work for me with obj and I tried also with raw and lwo with no luck …
Very frustrating.

EDIT: After fiddling around for hours I discovered something. BTW the problem is just in VRay, Rhino renderer and materials seem to work fine.
The problem is assigning channels to different maps. I had the general surface map with bump to channel 1, a logo in channel 2 and a displaced bitmap in channel 3. It appears that if I put the logo in channel 1 it displays fine, so it depends in what order the channels/maps are it makes a difference.
Juan