Map uniformly onto polysurfaces

Hi, I have a set of trimmed and untrimmed surfaces I need to apply a pattern to as if they were a single entity and considering their normals.
Upon mapping the pattern it results in individual behaviors for each surface. Things I’ve tried:
-MergeSrf on Rhino (doesn’t work with trimmed surfs)
-Brep join in GH (no effect resulting from this)

Any advise is extremely useful as I haven’t seen any conversation on this topic which seems to be essential.

Thanks! (275.4 KB)

I think there are many discussions on this type of subject but there is not one answer. It is quite similar to :

  • texture placement (a rectangle),

  • meshing with quads …

As you have just 3 borders there will be some big distorsion il you want to put exactly a rectangle.
You could look at that

Here one solution

So I mirror 2 times your structure, join it, cap it (to be solid) then I made a centered square drape above. The apply the Kangaroo script then the mesh result is transformed in surface and you could apply the pattern you want. (218.6 KB)


Thank you. This is extremely close to the perfect solution, I just need to tweak the undercut created at the edges. I have a problem with the plug-in Kangaroo components V1 which is nowhere to be found, I assume that’s the reason I can’t change or even find the Gravity component. Do you reckon it has any impact?

If you have problem cutting the curves tell us.
For Kangaroo I don’t understand your we question. Kangaroo is there surely 0.099 version

It’s simply that by opening the file the application keeps asking for the information on the attached screenshot. I assume it’s OK to just ignore it.
I’ll keep working with this and let you know if any issues. Thank you very much!

you may also want to consider remaking/approximating the entire geometry as a networkSrf

Laurent, in order to resolve the undercut created by the draped surface (attached screenshot) I extended the bottom of the Brep. However, upon replacing the old with this new Brep nothing happens to the subsequent elements. Is there anything in particular that’s missing?

0081Mesh_drape_quad(2).gh (257.2 KB)

I’m also confused by this. I tried to open your file, and get the following, despite having downloaded the thing from the food4rhino link (which seems to be an older version of what’s already included with Rhino these days?):


However, now that I downloaded the similarly named thing from that site, I do see the hexagons (which I didn’t see before… but the error messages remain).

Also, I no longer see any unblock option…