Manipulating NamedCPlane causes grid snap size(spacing) to change

Updating CPlane with namedCPlane is causing the grid snap size to change.
The same thing happens when I update CPlane through Oneview.

  1. Command SnapSize to change snap size to 100 or whatever
  2. Add new named CPlane
  3. Change current CPlane via NamedCPlane pane or Oneview
  4. Check snap size: it’s reset to 1

Is this intentional or a bug?

I’m using R7.
(7.36.23346.16351, 2023-12-12)

Hello - so far I do not see this here.

-Pascal

Hi thanks for the answer.
So is this just happening to me?
Reinstalled rhino and restored all options but still same.

Hello- can you post a file with the settings and the named cplane you are testing?

-Pascal

files:
test_CPlane.3dm (146.0 KB)
test_CPlane.ini (153.5 KB)

Thanks, the video is helpful.
@bohun9610 - see if SnapSize > ApplyTo=AllViewports makes it more stable.

-Pascal

Tried but there’s no difference.
Still not seeing any issue on your end?

I just tried with my Mac as well, and the same thing happens.