Managing projects

Hello there,
I wonder if there is some good option for managing projects. I mean, I would just like to split a model into several parts, just to have access for several designers. Sounds easy, but having tried the basic two options I am stuck a bit. The first picture is the basic model, and I’d like all of the parts to look alike:

These are my regular settings for displaying various VA elements. So, the first attempt was to attach this model to a “master” file as a basis, and something went wrong:

The block is attached as an “embedded and linked”, with marked “read linked blocks from the file”. First of all, there are a lot of missing blocks, including walls, slabs etc. Then, there are some some extended elements, as curtain walls, and it looks like boundary elements are missing, although they are still in the attached model… As you can see, even the materials properties are changed… At this point I tried the second option and I have set up a worksession…:

…and it was almost successfull! Almost… The model itself seems to be OK, but still plan and section don’t look good, as well as materials…
It may be I have missed some points, but what points? Do you have any idea? Or maybe do you have your own methods for this?
Cheers, Jaro


Nobody? Nothing? Even @fsalla? Or @enric? :wink:

Hi @jerry.bakowski,
The option to handle this as a Master file where you insert the different parts as “embedded and linked” blocks is the way to go, since VisualARQ doesn’t support workessions (that’s why you don’t see the model in section properly).
We would need to check the “master” file and referenced files to see what’s going on with all these errors you are getting. Please send them to

1 Like

Hello Francesc,
I have sent the files.
And as I have written, this is a master file with an attached model, linked and embedded. I think the problem is with elements’ IDs, maybe they get changed when inserted into another file?
Cheers, Jaro

Hi Jaro,
Got your files! I get the same errors. We will work to fix them. I’ll keep you posted.

@jerry.bakowski if you update the inserted file from the Block manager, do all these curtain walls and missing walls appear correctly?

As regards the problems with the textures, it seems a bug in Rhino. If you open the MASTER file, Rhino does not generate the files for the textures. If you first open the MODEL file, Rhino will save the textures to disk. Then, if you open the MASTER file, the textures will be shown.
This can be reproduced with or without VisualARQ loaded.

Hello Francesc,
I have tried updating, and for a while I was almost happy :wink: It looked good and promising, until I closed the block manager window. See the story below:
1/ the master file opened:

2/ updating block, with the option for keeping imported blocks:

3/ file successfully updated, hurrah!

4/ oh no, here we go again, just after closing block manager window:

So, it seems to me there must be a bug with managing such files…
Cheers, Jaro

Hi Jaro, indeed, it seems there’s some bug with the extension of those curtain walls. We are currently working on it…

Hi Jaro,
All these issues reported here have been fixed in VisualARQ 2.11, that has been just released: VisualARQ 2 - Version 2.11 released

Hello Francesc,
I didn’t have time to check back this project, but there is a problem with displaying linked referenced files. Take a look at the pictures. This is how a project with a reference file (external block) looks like when printed:

There are some wrong use of textures (at both files there are the same materials), wrong transparencies, wrong display of walls behind elements with transparent textures and so on.

When I explode the file, and the explode the block it looks fine:

So, this is the effect I’d like to get - but I can’t in the neat way… What to do to get this still having and using external blocks?

Cheers, Jaro

And small update - the vaSectionView and vaPlanView commands ignore linked and referenced blocks, too. Live plans and sections are valid:

Cheers, Jaro

Hi @jerry.bakowski,

Please, could you share this file with us sending it to I’ll take a look to see what’s going on…

If I understood well… You explode every VisualARQ object and, afterwards, you print out the layout again and you get the desired result?

About this, VisualARQ supports embedded and linked files, I tried to reproduce this error linking a file this way and it looks like it is working fine. How did you reference the files? Could you share this file with us as well?


Hello Alfonso,
I have sent you the 2 crucial files :wink:

Not exactly. The outer elevation is made with SkinDesigner, so it consists of regular Rhino blocks. Of course, all SkinDesigner elements are baked. This part is a single file, inserted to the master file as a referenced and linked block. The master file is the rest (ok, almost the rest) of the design geometry and all of these elements are VisualARQ objects. And they are fine. To get proper effect of the outer elevation when printed, I’ve had to explode this file only, the whole rest is untouched. And then I have printed layouts. The results you can see just above.

Without my file I doubt you could reproduce the problem :wink: now you can :wink:
OK, the file is just “linked”, not “embedded and linked” - but what is the difference? I could experiment with both methods, but as you may know from other topics I also experience some lags, so I am not enough patient :wink:
Cheers, Jaro

Hello @jerry.bakowski,

About the first issue: which display mode are you using to print the layout? Which Rhino version are you using? I tried to reproduce the issue with your file but I get the same result leaving the gemetry as VisualARQ objects or exploding them, so maybe it is a problem with the skin… Maybe I am missing something, what I did was printing the “ELEWACJA-1” layout with the Realistic display mode, then I did the same but having exploded all the VisualARQ objects in the file and in both cases I got the same result.

About this, VisualARQ doesn’t support linked blocks, so you need to embed and link them.

Hello Alfonso,
I will send you files as soon as possible.
I use Rhino 6 (6.34.21034.7001, 02/03/2021) and VA 2.11 (
Changing external block to “embedded and linked” doesn’t work: Here is the same model with a “embedded and linked” block, at realistic display:

Layout display and printing give the same results as a “linked” method.
Cheers, Jaro

And small a small addendum: the same model, but with outer elevation removed, or just with hidden layers:

It seems to me that there is some problem with handling external blocks. Or my block is invalid…
Cheers, Jaro

Hello @jerry.bakowski,

Now I could get the same result as you in the printed layouts. However, I got this result exploding only the block; you don’t need to explode the VisualARQ objects to get that result, so I think maybe the problem is in the skin. I don’t know if exploding the block at the end of the script, before baking it from Grasshopper to Rhino, could be an option… I will add this issue to our bug list with your vote.

About this, did you try linking and embedding all the files? I did it that way and it worked. If it doesn’t work anyway, please, let me know and I’ll send you the next VisualARQ release (which will be published in a few days), just in case.

Hello Alfonso,

Well, I never said I had exploded VA objects… I just realized the outer elevation was the problem and it messed with display modes. Exploding it was the worst option, as I needed to work on it using a separate file. I am pretty sure you can find a good solution so I can keep my workflow :wink:

Your sample looks like it should be. Is the skin exploded or still an external block? Anyway, I have finished the project, when I have a time I will take a look at this again.
Thank you for your help!
Cheers, Jaro

Hi @jerry.bakowski,

It is still an external block, but all the files have been linked and embedded. We are working to support linked files as well but, for now, this is the best option.


@jerry.bakowski VisualARQ 2.12 is out, and includes support to worksessions:

The main limitation of this enhancement is that VisualARQ objects that are inside a non-active worksession document cannot be copied using the Copy or the CopyToClipboard commands. Hopefully we will improve this in future releases.

Check the full news here: VisualARQ 2.12 available - VisualARQ