Making MeshSplit work on this geometry

Hello Giulio,

Question about MeshSplit: Are you able to make this work?

MeshSplit_TestCase.3dm (963.8 KB)



1 Like

Hi Alexandre, @Alexandre_Filiatraul

I moved this to a new topic, because this did not have much to do with the original question.
Here you asked:

Sure thing. The problem with this case is that the splitter is actually questionable geometry. The mesh that I think you want to divide, on the other hand, is very good geometry. So, all we have to do is improve the geometry of the splitter. Let’s see where and how.

  • The first problem, that certinaly is not helping, is that the splitter is extruded quite high. In and by itself, this should not prevent the split, but definitely, it makes splitting more difficult.
  • The second problem, marked with the letter A, contains triangles that are very tall and narrow, and actually are pointing exactly toward the split location along the mesh that we need to split. We should get rid of this problem
  • Lastly, and marked with the letter B, there’s triangles that align with the mesh that we want to split. Again, this alone is not enough to make certain that the split will not succeed, but this is an unnecessary difficulty added for this simple case.

Here, I am showing how to mend the splitter geometry so that it is accurate, and the split works easily.

  • _Rebuild the curve on the layer Input_Curve. I use 300 points and degree 3.
  • ExtrudeCrv with BothSides=Yes Solid=No. You can use Alt to remove snapping temporarely.
  • Mesh the resulting surface. You can pick options, at best not some that add vertices halfway in the mesh. I get the mesh shown here below.

  • MeshSplit works. We could have also just used the rebuilt curve, but then it would have been impossible to pick a particular mesh setting.

Here the file. MeshSplit_TestCase_fixed-geometry.3dm (1.7 MB)
Does it help?



Giulio Piacentino
for Robert McNeel & Associates

EDIT: I want to mention that the split is actually a lot more complicated than in looks. Rhino 7 by default groups original faces into ngons. Here you can see the difference with and without _DeleteMeshNgons:

1 Like

Thank you Giugio!

I’m much more confident now; that solution seems a lot more robust. I effectively did notice that the border is indeed very clean.

Have a good holyday!


A post was split to a new topic: MeshSplit and MeshTrim not working well, video