Making 2d of blocks is wack


#1

attached is a sweet bleachers set up.

I made it in such a way that the structure and railings can be turned off by layer so that when making a 2d plan you can simply use the carpet surface as the drawing base.

it doesn’t work.

instead my i7 12 core computer stalls forever trying to make 2d. I’m pretty sure it is because it is calculating the elements of the block that are not visible. THAT MAKES NO SENSE. Please allow blocks to work with make 2d! I should not have to explode a block to get a drawing of it!!

thanks,

Aaron

bleechers03.3dm (16.5 MB)


#2

Hi Aaron,

the long waiting time seem to be related to invalid geometry in your block. If you double click the block and then highlight “railing block” you should get below error message (CheckNewObjects needs to be enabled i guess):

the problematic surface seems to be located in the bottom cap of the railing…

c.


#3

Even if that is true why is rhino calculating an object that is not visible?

I edited the block and repaired the bad object, the thing still won’t draw for me, howabout for you?

bleechers04.3dm (16.4 MB)


(Wim Dekeyser) #4

I just tried quickly by setting the document tolerances to 1 inch. It took only 5 minutes or so to complete the Front view. So basically, making 2d of blocks does work.


#5

“Only 5 minutes” good one.


(Wim Dekeyser) #6

What are you going to use the output for?


#7

Hi Aaron, i did not gone that far as wim. As long as the nested block defninition contains multible bad objects, it made no sense to me to try Make2D at all. :wink:

c.


(Pascal Golay) #8

Hi Arron - I quick test with some blocks shows that Rhino is at least not drawing the hidden layers in blocks in make 2d; I do not know if it is ‘considering’ them somehow. In any case, I see that all is not right with your example, I’ll get it on the pile for the developer.

thanks,

-Pascal


#9

Not sure what you’re saying here. But the problem persisted after fixing all objects.


#10

Thanks Pascal.


(Pascal Golay) #11

HI Aaron- it looks to me like this may be due to the complex blocks, the blue ones and railings, existing, as instances, on the Bleechers layer- this is a parent layer to all of the other ones there and I am guessing that Make2d is not handling this situation correctly- that is, it can’t tell what to do with objects that are on both an ‘off’ layer and on an ‘on’ layer.

If I blockEdit and move one of each of the Bleecher Bijax blocks to the ‘bleecher bijax’ layer and one of the railing blocks to the Railings layer, then Make2d with only Carpet on works fine. I also tried moving all of these instances to a new layer at the same level as ‘carpet’ etc. If this layer is on, then the make2d bogs down even of only ‘carpet’ is visible; if this new layer is off, then make2d is quick on the ‘carpet’ only objects.

-Pascal