Make2D works in perspective view but not ortho view?

Hello. I’m having trouble getting a 2d view from Rhino6 using the make2d command. The command works fine when I use it on a perspective view and produces good results.

However, in an orthographic view, for example, when looking at the model from the front, the make2d command produces wonky results missing a large number of lines and is completely unusable. I need the command to produce an accurate elevation drawing for construction documents. Since this is an actual production model for an ongoing construction project, I can’t upload the model. I will attach an image of the results from both views below.

I have tried moving the model to the origin, change tolerances and also changed units. None of them worked. Perspective view produces good lines each time, the orthogonal view does not. Is this a problem with the software or my model? Thanks.

Hello - are the missing curves actually missing, or are they incorrectly classified as hidden? If you run Make2d asking for hidden lines (might take a long time, I guess, on this ) do you get the curves?


They are surface edges that are just not appearing after the Make2D operation. They do appear when I do the same operation in perspective view though. I tried Make2D with the hidden lines option enabled, it produced the wire frame of the model, which is too complicated to clean up.

Luckily for me, Rhino 5 stepped in to save the say. Albeit taking much much longer, it was able to produce good Make2D results from orthogonal views. I’m perplexed as to why Rhino6 can’t do the same operation correctly.

You didn’t mention if it included the missing curves.

The code was rewritten to fix bugs. Without examples that we can check, we will not be able to fix remaining issues with the Rhino 6 code. It would help a lot if you could upload your file here:

Finally, which SR of Rhino 6 are you running?

I have the same problem. Make2d works great in perspective view but fails in parallel projection. As you suggested a lot of lines are incorrectly categorized as hidden lines. I could upload an example model if necessary? I’m running SR10.

Yes, please.
Please try to reduce a file to only include what is necessary to replicate a problem. If it’s a file that doesn’t contain sensitive information, just attach it here. Else you can send it to me in PM or use the upload page.