Make2D wish


#1

Hi,

Is there any chans to add object properties to the comandline when using “-_Make2d”?

image

Best regards


(Pascal Golay) #2

Hello - here’s how it looks in the latest V6:

Is your image from the V7 WIP?

-Pascal


#3

Hi Pascal,

I thought I just updated some days ago, didn’t know there already was an update.
Thanks for the info!

Cheers


#4

Hi Pascal,

I have tried both version 6.4.18124.12321, and 6.5.18128.14431.

In neither of them your option is found.
Is there a nother version that I should try?

Cheers


#5

FWIW, here on (6.6.18132.1341, 2018-05-12) this is what I get:


#6

What is the newest release and where do I find it?
Until now I have only used update inside Rhino and there I 6.5 as the newest one.

Cheers


#7

The latest stable release is 6.4. From within Rhino, you can opt to install release candidates (RC) for the next SR - which is why you are now running a 6.5 RC. I am running in-house daily versions of 6.6.

The point I was trying to make is that, just like you, I don’t have the options that Pascal showed from his system. So there must be something, somewhere that exposes the options on Pascal’s installation.

Also, since this is a RH6 question, I’m changing the category from Serengeti to Windows.


#8

Alright, then I’ll step aside and let you two handle this issue =)
Thanks in advance!

Cheers


#9

hi,

Just for notice.
I installed RC 6,5 and the properties are still missing.

Cheers


#10

Any update on this issue?

Cheers


(Nathan 'jesterKing' Letwory) #12

@socken, could you post the results of the Rhino command _SystemInfo?

FWIW I see the Properties option on the -_Make2D command in 6SR4.


#15

Rhino 6 SR5 2018-5-12 (Rhino 6, 6.5.18132.5131, Git hash:master @ b8b8945d46018b7f175f54f1e384ede46df9745d)
Licence type: Commercial, build 2018-05-12
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: SLSOBER

Quadro M1000M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.33)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-22-2018
Driver Version: 23.21.13.9133
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


#16

bumping this thread in hope of some help


(Pascal Golay) #17

Thanks for the bump - oddly, we’re still arm-wrestling here about who can see this and who cannot - so far it is inconsistent and mysterious, I’ll try to figure out what’s going on.

@socken, @wim - are you running in English Windows? Rhino?

-Pascal


#18

@pascal, both Rhino and Windows are in English here.
image

image


#19

If this can help …

I see the Properties option here

Systeminfo:

Rhino 6 SR4 2018-5-10 (Rhino 6, 6.4.18130.19341, Git hash:master @ 51190de75f80526c68ef8bdf62938fe1eb6ccc8a)
Licence type: Not For Resale, build 2018-05-10
License details: Cloud Zoo. In use by: emilio morello ()

Windows 8.1 (Physical RAM: 7.9Gb)
Machine name: PC-2014

GeForce GT 740M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Windows 8.1 in Italian
Rhino in English


#20

Hi,

been off for a while,
Windows = English
Rhino = English

Cheers


#21

@pascal , Any new info on this issue?
Updated to 6.8.18211.21311, 2018-07-30 today, but still no properties option here.

Cheers


#22

@socken, I just checked my system again - running in-house (6.9.18215.21461, 2018-08-03).

I was surprised to see that the Properties option now did appear on the command line:

I saw that the Layout setting was set to CPlane and I wanted that to be the same as in screenshot that I posted earlier. I ran the dialog version of the command and changed to FirstAngleProjection.

Now, running the commandline version shows this:

… the option is gone again.

Running the command through the dialog with Third angle projection brings the option back to the command line:

Also,
As a workaround, I thought I’d check if toggling the Layout option would perhaps let you set the Properties option while in e.g. CPlane mode and then, when that is as you want, change the Layout back to FirstAngleProjection but it seems that you cannot change the Layout on the command line. You can bring up the options and pick a different one, but that won’t stick.

@pascal, if you can repeat this on your system, I can make the YT items…


#24

@wim, I did test it in my version aslo (6.8) and it’s only in the “first angle projection” that the properties doesn’t show.

Cheers