Make2D will not generate secondary options window nor any 2D drawing

Hi there. I recently have run into an issue with the Make2D command on my rhino 6 software. When I type and run the Make2D command, nothing happens. Not even the secondary window where you have the option to tweak the views, layer output, etc. I simply run the Make2D command and nothing occurs. I have updated my windows, uninstalled and reinstalled my Rhino 6, changed files but to no avail. I recently updated my motherboard’s BIOS and Graphics card drivers; however, I don’t know if this can have any impact on my issue. Another odd thing about the situation is that the Grasshopper make 2D node and computation works, but not the original Make2D command. Please let me know if anyone has help on this issue.

Hi Martin - can you run the Leader command, or Text?

Hi Pascal,

Thanks for getting back to me. I can successfully run those commands with their secondary pop up windows generating as well.

OK - thanks - the Make2D command is in the same plug-in as these so that plug-in is clearly loading… Can you try it from a toolbar, (Drafting toolbar )?


Anything? If there is no selection the command line will prompt you to select objects.


I just tried that and unfortunately nothing happened again.

Hi Martin - hmmm - no great ideas at the moment but can you please try starting Rhino in Safe Mode

Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.

Does that behave any differently?

@rajaa - do you have an idea?


First time I hear this happening.
Can you run -Make2D (in script mode) to see if opening the dialog is a problem?

I tried to run Make2D in safe mode but that didn’t seem to have any effect. How do I run Make2D in script mode? I’d be happy to try that.

just run -Make2D

Hi Rajaa,

That worked! The pop up window with the options did not appear, but they were there on the command line. Is there any advice you may have to make the pop up window appear for convenience? Thank you for your help regardless.

I wonder if the graphic card is the problem. Are you able to open the dialog when you run a command like ViewCaptureToFile?

Yes I am. It’s very odd, Make2D is the only command that doesn’t have its dialog open when run

Can you try to open new file, draw a box and run Make2D?
If it does not work, can you copy/paste your SystemInfo here? (run SystemInfo command)

That did not work either. Please see SystemInfo below -

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Evaluation, build 2020-08-25
License details: Cloud Zoo. In use by: Martin Lee ()
Expires on: 2020-11-08

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-4DFDIE2

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-12-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

@pascal any thoughts on how we can replicate this error?

None so far… I wonder if the dialog is turning up off screen maybe? @martin.craig.everett do you have a second display?


Yes I do; however, the dialog doesn’t appear on the second display either.

Shot in the dark: With only one Rhino running, testResetWindowPositions, then close and reopen Rhino.



Still nothing :frowning: I also tried only running one display and that didn’t do anything either.

Hi Martin - just making sure… if you run the command with no pre-selection, do you at least get the prompt to select objects? It is looking like showing the dialog is the bottle-neck, but I just want to be sure the command even gets that far.